Bug 244218 - nouveau doesn't recognize correctly GeForce Go 7300
nouveau doesn't recognize correctly GeForce Go 7300
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 11:45 EDT by Nicola Soranzo
Modified: 2008-05-20 09:43 EDT (History)
0 users

See Also:
Fixed In Version: xorg-x11-drv-nouveau-0.0.10-2.20080408git0991281.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 09:43:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf and Xorg.0.log for both nv and nouveau (12.93 KB, application/x-gzip)
2007-06-14 11:45 EDT, Nicola Soranzo
no flags Details
nv configuration (852 bytes, text/plain)
2007-06-15 09:56 EDT, Matěj Cepl
no flags Details
nv log (41.98 KB, text/plain)
2007-06-15 09:57 EDT, Matěj Cepl
no flags Details
noveau config (855 bytes, text/plain)
2007-06-15 09:57 EDT, Matěj Cepl
no flags Details
noveau log (40.40 KB, text/plain)
2007-06-15 09:58 EDT, Matěj Cepl
no flags Details
Xorg log for nouveau 2.1.5 (80.45 KB, text/plain)
2007-09-29 12:28 EDT, Nicola Soranzo
no flags Details

  None (edit)
Description Nicola Soranzo 2007-06-14 11:45:58 EDT
Description of problem:
I think that my video card GeForce Go 7300 (NVS 110M) is "supported" by the new
nouveau driver, so I tried to change from nv (which works) to nouveau via
s-c-display. After restarting X, the maximum video resolution becomes only
800x600, instead of the previous 1280x800.
If I select again nv driver via s-c-display, all works again.

Version-Release number of selected component (if applicable):
2.0.96-2

How reproducible:
Always

Steps to Reproduce:
1. Open system-config-display.
2. Under Hardware, Configure video card, select nouveau
3. Close session
  
Actual results:
Maximum video resolution is 800x600.

Expected results:
Maximum video resolution should be 1280x800, as when using nv driver.

Additional info:
I attach conf and log files for both nv and nouveau.
Comment 1 Nicola Soranzo 2007-06-14 11:45:58 EDT
Created attachment 157013 [details]
xorg.conf and Xorg.0.log for both nv and nouveau
Comment 2 Matěj Cepl 2007-06-15 09:56:48 EDT
Created attachment 157111 [details]
nv configuration
Comment 3 Matěj Cepl 2007-06-15 09:57:06 EDT
Created attachment 157112 [details]
nv log
Comment 4 Matěj Cepl 2007-06-15 09:57:27 EDT
Created attachment 157113 [details]
noveau config
Comment 5 Matěj Cepl 2007-06-15 09:58:32 EDT
Created attachment 157114 [details]
noveau log

Please, don't attach tarballs next time -- it's much more complicated to deal
with them (e.g., curl URL | less)
Comment 7 Dave Airlie 2007-09-25 19:22:56 EDT
can you retest with the nouveau in Rawhide by any chance?

really nv and nouveau shouldn't act differently with modesetting they use the
same code...
Comment 8 Nicola Soranzo 2007-09-29 12:26:23 EDT
(In reply to comment #7)
> can you retest with the nouveau in Rawhide by any chance?
> 
> really nv and nouveau shouldn't act differently with modesetting they use the
> same code...

I installed xorg-x11-drv-nouveau-2.1.5-1.fc8 and
kernel-2.6.23-0.211.rc8.git2.fc8 on my Fedora 7 and now the video resolution is
correct (1280x800). Some redrawings (e.g. scrolling on web pages) are very slow,
but the system is usable.
Reading the Xorg log file, it looks like that Nouveau doesn't recognize the card
as GeForce Go 7300, but as NVIDIA NV46 (nonexistent chipset, AFAIK).
Comment 9 Nicola Soranzo 2007-09-29 12:28:28 EDT
Created attachment 211391 [details]
Xorg log for nouveau 2.1.5
Comment 10 Nicola Soranzo 2008-05-20 09:43:43 EDT
In Fedora 9 my card is recognized correctly, closing.

Note You need to log in before you can comment on or make changes to this bug.