Bug 244286 - XFCE DPI issue introduced in 4.4.1
XFCE DPI issue introduced in 4.4.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce-mcs-plugins (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 16:09 EDT by Ray Van Dolson
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.4.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 11:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add DPI specification to User Interface Settings dialog. (14.17 KB, patch)
2007-06-14 16:09 EDT, Ray Van Dolson
no flags Details | Diff

  None (edit)
Description Ray Van Dolson 2007-06-14 16:09:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):
4.4.1-1.fc7

How reproducible:
Always

Additional info:
I originally noticed this in FC6 when upgrading from XFCE 4.4.0 to 4.4.1. 
Apparently in the past XFCE enforced a DPI setting of 96.  In 4.4.1 they removed
this enforcement and left it up to the X driver to detect the DPI.  This
detection often does not work correctly, and as a result my DPI was being set
higher than 96 and my application fonts were much larger than before.

I was able to work around this issue by setting Xft.dpi to 96 in my
~/.Xresources file, however, I discovered an XFCE bug covering the same topic
and possibly a better solution:

http://bugzilla.xfce.org/show_bug.cgi?id=3164

XFCE has modified ui_plugin to provide an additional option for specifying the
DPI from the User Interface Settings dialog.  This would seem to be the best
solution.

I merged in their patch into the current xfce-mcs-plugins RPM and it has worked
great for me.

The only caveat is that this is tagged for their 4.4.2 release.  Would you
typically wait until 4.4.2 is final before including this patch?  It would be
nice to have now, but obviously this isn't anything super-urgent.

I will include my Fedora-ized version of the XFCE patch.
Comment 1 Ray Van Dolson 2007-06-14 16:09:31 EDT
Created attachment 157039 [details]
Patch to add DPI specification to User Interface Settings dialog.
Comment 2 Kevin Fenzi 2007-06-14 19:22:09 EDT
Interesting. This is the first report I have had of this issue... 

Will take a look and see. Thanks for the bug report!

Typically, yeah, I would wait for upstream to release 4.4.2... but if it's not
very invasive or if it's a major problem it might be worth carrying a local patch. 
Comment 3 Ray Van Dolson 2007-06-14 19:39:59 EDT
Let me know if you are unable to reproduce.  It seems that /etc/X11/Xresources
includes a DPI setting, but this seems to be ignored by my XFCE -- however my
~/.Xresources is not.
Comment 4 Kevin Fenzi 2007-07-31 01:41:44 EDT
Sorry for the long delay here... I was hoping 4.4.2 was going to be out pretty
soon, but it looks like it might be a while.

I have gone ahead and built this for devel and requested a push for
updates-testing in f7. If you could test and confirm it works for you, that
would be great. 
Comment 5 Fedora Update System 2007-07-31 18:52:01 EDT
xfce-mcs-plugins-4.4.1-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ray Van Dolson 2007-07-31 19:07:28 EDT
So far so good.  Thanks for updating the package!
Comment 7 Fedora Update System 2007-08-08 11:29:11 EDT
xfce-mcs-plugins-4.4.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.