Bug 244347 - "Pointer Grabbed" bubble popup annoying
"Pointer Grabbed" bubble popup annoying
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 04:15 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 17:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-06-15 04:15:00 EDT
Description of problem:
When one clicks into a virtual console window and the pointer is grabbed
a "bubble popup" appears explaining that the mouse pointer has been grabbed.
After a while this gets pretty annoying.  There should at least be an option
to turn it off or maybe it is not necessary since the information also
appears in the window titlebar.

How reproducible:
every time

Steps to Reproduce:
1. click in console
  
Actual results:
Bubble appears covering part of console for some seconds:
in particular the top gnome panel is covered and hard to access
during this time.

Expected results:
Popup not to cover console or not to appear.
Comment 1 Nathan Watson 2007-06-19 07:43:48 EDT
I agree.  This is annoying.  Are there any settings to turn it off?

The UI should put one of those check-boxes in the bubble saying
"Do not show this message again [..checkbox..]" and default it
to 'false' (i.e., show again by default).  If user selects the
box, then the bubble don't come up no more.
Comment 2 Nathan Watson 2007-06-19 07:44:44 EDT
And for comment 1, this was in Fedora 7 final release.
Comment 3 Daniel Berrange 2007-06-19 13:37:04 EDT
I just comitted a fix for this upstream. It will be included in the next release
of virt-manager and thus make its way into a Fedora update

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=4df620fc9133

Comment 4 Red Hat Bugzilla 2007-07-24 22:13:57 EDT
change QA contact
Comment 5 Daniel Berrange 2007-09-27 17:25:53 EDT
In virt-manager-0.5.0 it is possible to get rid of this popup permanently now.
Comment 6 Jens Petersen 2007-10-15 21:03:24 EDT
Seems pointer grabbing is gone now (running 0.5.2), or I don't see how
to enable it... but that works for me. :)

Note You need to log in before you can comment on or make changes to this bug.