Bug 244348 - Better ImageableArea default when no margins information available
Better ImageableArea default when no margins information available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: foomatic (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
: FutureFeature, Reopened, Triaged
: 252008 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 04:26 EDT by Tim Waugh
Modified: 2010-10-22 11:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 03:57:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Back-ported patch. (858 bytes, patch)
2009-01-23 07:27 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2007-06-15 04:26:50 EDT
This applies to Red Hat Enterprise Linux 5 as well.

+++ This bug was initially created as a clone of Bug #244161 +++

Description of problem:
The PPDs foomatic creates for printers where no margin information is known are
too optimistic with their ImageableArea settings.  They should use conservative
guesses (say, ½" border all round) in that case.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-47.fc7

How reproducible:
100%

Steps to Reproduce:
1. foomatic-ppdfile -p Epson-Stylus_D68 -d gutenprint-ijs.5.0 | grep ImageableArea
  
Actual results:
0-margins

Expected results:
36-margins, for example

-- Additional comment from twaugh@redhat.com on 2007-06-14 06:44 EST --
Created an attachment (id=156978)
foomatic-margins.patch

Untested patch.

-- Additional comment from twaugh@redhat.com on 2007-06-14 07:59 EST --
Fixed in CVS (trunk).

-- Additional comment from updates@fedoraproject.org on 2007-06-14 11:46 EST --
foomatic-3.0.2-47.1.fc7 has been pushed to the Fedora 7 testing repository.  If
problems still persist, please make note of it in this bug report.
Comment 2 RHEL Product and Program Management 2007-06-15 04:34:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 4 Tim Waugh 2007-08-14 05:20:09 EDT
*** Bug 252008 has been marked as a duplicate of this bug. ***
Comment 6 RHEL Product and Program Management 2007-12-03 15:43:26 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 9 Phil Knirsch 2008-04-30 11:52:31 EDT
Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil
Comment 10 Phil Knirsch 2008-05-14 10:19:43 EDT
Proposing bug for RHEL-5.3 FasTrack.

Read ya, Phil
Comment 11 RHEL Product and Program Management 2008-05-14 10:20:51 EDT
This bugzilla has Keywords FutureFeature and thus does not meet the
release criteria for FasTrack. This FasTrack request has been denied.
This bugzilla must be addressed in a minor release.
Comment 13 Tim Waugh 2009-01-23 07:27:14 EST
Created attachment 329813 [details]
Back-ported patch.
Comment 20 errata-xmlrpc 2009-09-02 03:57:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1240.html

Note You need to log in before you can comment on or make changes to this bug.