Bug 244351 - reposync (yum-utils) not sync, but do full download
reposync (yum-utils) not sync, but do full download
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 04:33 EDT by Alexander
Modified: 2014-01-21 17:58 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.1.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 05:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander 2007-06-15 04:33:01 EDT
Description of problem:
I would like to have a copy of repository updates for F7 on my server (only
newest packages). I use utility reposync from yum-utils. But it download all
newest packages at each run.
Yesterday it downloader 1,5 GB packages. Today I run it again and it rewrite all
packages, that placed in the folder.

Version-Release number of selected component (if applicable):
# rpm -q yum-utils
yum-utils-1.1.4-1.fc7
# cat /etc/fedora-release 
Fedora release 7 (Moonshine)



How reproducible:
# cat /etc/yum.repos.d/fedora-updates.repo 
[updates]
name=Fedora $releasever - $basearch - Updates
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

In folder:
# ls CG*
CGAL-3.3-4.fc7.i386.rpm  CGAL-demos-source-3.3-4.fc7.i386.rpm 
CGAL-devel-3.3-4.fc7.i386.rpm

I run:
/usr/bin/reposync --newest-only -r updates -p /mnt/data/Fedora-Updates/updates
and I see:
Downloading CGAL-3.3-4.fc7.i386.rpm
Downloading CGAL-demos-source-3.3-4.fc7.i386.rpm



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gianluca Varisco 2007-06-17 09:13:07 EDT
I can confirm what Alexander reported, I have the same problem with reposync.
Comment 2 Tim Lauridsen 2007-06-19 02:08:48 EDT
Please try yum-utils 1.1.5 in updates-testing, it have some fixes to reposync
there might solve this issue.

yum --enablerepo=updates-testing update yum-utils

Comment 3 Alexander 2007-06-19 04:47:48 EDT
I tried yum --enablerepo=updates-testing update yum-utils
after updating command reposync works fine. Last line from stdout:
[updates: 866   of 869   ] Skipping existing zenity-2.18.2-1.fc7.i386.rpm
[updates: 867   of 869   ] Skipping existing zvbi-0.2.25-1.fc7.i386.rpm
[updates: 868   of 869   ] Skipping existing zvbi-devel-0.2.25-1.fc7.i386.rpm
[updates: 869   of 869   ] Skipping existing zvbi-fonts-0.2.25-1.fc7.i386.rpm

Comment 4 Tim Lauridsen 2007-06-19 05:31:21 EDT
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.