Bug 244359 - Update of xorg-x11-server-Xorg cleans section "files" in xorg.conf
Summary: Update of xorg-x11-server-Xorg cleans section "files" in xorg.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-15 09:20 UTC by Sebastian Vahl
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 14:08:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian Vahl 2007-06-15 09:20:17 UTC
Description of problem:
When doing an update of xorg-x11-server-Xorg the section "Files" in xorg.conf 
will be cleaned. Also it won't create a backup.
In my case I have the following entries in it:

Section "Files"
        ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
        ModulePath   "/usr/lib/xorg/modules"
EndSection

Without this entries X will crash when starting beryl with the propr. nvidia 
driver.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-8.fc7

How reproducible:
Everytime

Steps to Reproduce:
1. update xorg-x11-server-Xorg
2. see xorg.conf
3.
  
Actual results:
files section is empty

Expected results:
Entries in files section should not be removed

Additional info:
If this is an intended behavior at least a backup of the xorg.conf should be 
created.

Comment 1 Adam Jackson 2007-06-27 14:08:55 UTC
xorg-x11-server 1.3.0.0-12 should no longer clobber ModulePath lines if one
exists matching /ModulePath.*nvidia/.

Comment 2 Roderick Johnstone 2007-07-05 09:04:15 UTC
Could we have this as an update for Fedora 7 please?


Note You need to log in before you can comment on or make changes to this bug.