Bug 244401 - yum-updatesd.conf man page does not correspond to actual options
yum-updatesd.conf man page does not correspond to actual options
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 09:55 EDT by Milan Slanař
Modified: 2014-01-21 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 14:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Slanař 2007-06-15 09:55:02 EDT
Description of problem:
"run_interval" is in config file while "runinterval" in man page
"do_download_deps" in config file is not in man page

Version-Release number of selected component (if applicable):
fc6 and f7

How reproducible:
always

Steps to Reproduce:
1.man yum-updatesd.conf
2.cat /etc/yum/yum-updatesd.conf
3. compare both
  
Actual results:
don't know which is correct

Expected results:
all options correctly documented

Additional info:
Comment 1 Gianluca Varisco 2007-06-15 14:01:47 EDT
According to yum sources
(http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum/yum-updatesd.py?revision=1.42&view=markup)
thery are defined as run_interval and do_download_deps.

So I think that there are few minor errors in the yum-updatesd.conf man-page.

The latest version of yum-updatesd.conf.5 man-page is available here
(http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum/docs/yum-updatesd.conf.5?revision=1.1&view=markup)
and it's broken too.
Comment 2 Jeremy Katz 2007-06-15 16:36:03 EDT
Fixed upstream; will be in 3.2.1
Comment 3 Milan Slanař 2007-06-17 03:20:49 EDT
Too quick fix :)
I have checked CVS revision 1.2 of man page and there is "do_download" section
added. Should be "do_download_deps". Reopening
Comment 4 Jeremy Katz 2007-06-18 17:09:36 EDT
Thanks; fixed
Comment 5 Milan Slanař 2007-06-19 04:30:59 EDT
Too quick fix again :)
Now both "do_download" sections have changed to "do_download_deps". First should
be "do_download" and the second one "do_download_deps". Reopening
Comment 6 Milan Slanař 2007-06-19 04:40:53 EDT
Right now I have noticed that "dbus_listener" option is also undocumented.
Comment 7 Fedora Update System 2007-06-21 18:03:39 EDT
yum-3.2.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Milan Slanař 2007-06-25 10:36:45 EDT
Problems persist. See comments #5 and #6
Comment 9 Fedora Update System 2007-06-27 21:48:46 EDT
yum-3.2.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Milan Slanař 2007-06-28 08:30:42 EDT
Not fixed.
Comment 11 Jeremy Katz 2007-09-13 14:24:39 EDT
Fixed-up in current -git of yum-updatesd.  Note that dbus_listener is
intentionally not being listed as it's almost certainly going to be going away
in the future

Note You need to log in before you can comment on or make changes to this bug.