Bug 24441 - glibc-2.2-12 still appears to be broken on RH 7.0
glibc-2.2-12 still appears to be broken on RH 7.0
Status: CLOSED DUPLICATE of bug 24442
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
4.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-19 22:14 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 22:14:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-19 22:14:34 EST
I have all the latest upgrades, still the kernel would not compile guys.
In fact it gave me a segmentation fault.

Kernel linux-2.4.0 would Not compile and gave the following error after a make mrproper; make xconfig; make dep; make clear; make bzImage

make[2]: Leaving directory `/usr/src/linux-2.4.0/arch/i386/kernel'
make -C arch/i386/mm fastdep
make[2]: Entering directory `/usr/src/linux-2.4.0/arch/i386/mm'
/usr/src/linux-2.4.0/scripts/mkdep extable.c fault.c init.c ioremap.c > .depend
make[2]: Leaving directory `/usr/src/linux-2.4.0/arch/i386/mm'
make -C arch/i386/lib fastdep
make[2]: Entering directory `/usr/src/linux-2.4.0/arch/i386/lib'
/usr/src/linux-2.4.0/scripts/mkdep checksum.S dec_and_lock.c delay.c getuser.S iodebug.c memcpy.c mmx.c old-checksum.c putuser.S usercopy.c > .depend
make[2]: Leaving directory `/usr/src/linux-2.4.0/arch/i386/lib'
make[1]: Leaving directory `/usr/src/linux-2.4.0'
make update-modverfile
make[1]: Entering directory `/usr/src/linux-2.4.0'
/usr/src/linux-2.4.0/include/linux/modversions.h was updated
make[1]: Leaving directory `/usr/src/linux-2.4.0'
make[1]: Entering directory `/usr/src/linux-2.4.0/arch/i386/boot'
rm -f tools/build
rm -f setup bootsect zImage compressed/vmlinux.out
rm -f bsetup bbootsect bzImage compressed/bvmlinux.out
make[2]: Entering directory `/usr/src/linux-2.4.0/arch/i386/boot/compressed'
rm -f vmlinux bvmlinux _tmp_*
make[2]: Leaving directory `/usr/src/linux-2.4.0/arch/i386/boot/compressed'
make[1]: Leaving directory `/usr/src/linux-2.4.0/arch/i386/boot'
find . \( -name '*.[oas]' -o -name core -o -name '.*.flags' \) -type f -print \
| grep -v lxdialog/ | xargs rm -f
rm -f kernel/ksyms.lst include/linux/compile.h vmlinux System.map .tmp* drivers/char/consolemap_deftbl.c drivers/video/promcon_tbl.c drivers/char/conmakehash drivers/char/drm/*-mod.c drivers/pci/devlist.h drivers/pci/classlist.h drivers/pci/gen-devlist drivers/zorro/devlist.h drivers/zorro/gen-devlist drivers/sound/bin2hex drivers/sound/hex2hex drivers/atm/fore200e_mkfirm drivers/atm/{pca,sba}*{.bin,.bin1,.bin2} net/khttpd/make_times_h net/khttpd/times.h submenu*
rm -rf modules
make -C Documentation/DocBook clean
make[1]: Entering directory `/usr/src/linux-2.4.0/Documentation/DocBook'
rm -f core *~
rm -f wanbook.sgml z8530book.sgml mcabook.sgml videobook.sgml kernel-api.sgml parportbook.sgml kernel-hacking.sgml kernel-locking.sgml via-audio.sgml mousedrivers.sgml sis900.sgml
rm -f  wanbook.dvi  z8530book.dvi  mcabook.dvi  videobook.dvi  kernel-api.dvi  parportbook.dvi  kernel-hacking.dvi  kernel-locking.dvi  via-audio.dvi  mousedrivers.dvi  sis900.dvi  wanbook.aux  z8530book.aux  mcabook.aux  videobook.aux  kernel-api.aux  parportbook.aux  kernel-hacking.aux  kernel-locking.aux  via-audio.aux  mousedrivers.aux  sis900.aux  wanbook.tex  z8530book.tex  mcabook.tex  videobook.tex  kernel-api.tex  parportbook.tex  kernel-hacking.tex  kernel-locking.tex  via-audio.tex  mousedrivers.tex  sis900.tex  wanbook.log  z8530book.log  mcabook.log  videobook.log  kernel-api.log  parportbook.log  kernel-hacking.log  kernel-locking.log  via-audio.log  mousedrivers.log  sis900.log  wanbook.out  z8530book.out  mcabook.out  videobook.out  kernel-api.out  parportbook.out  kernel-hacking.out  kernel-locking.out  via-audio.out  mousedrivers.out  sis900.out
rm -f  parport-share.jpeg  parport-multi.jpeg  parport-structure.jpeg  parport-share.eps  parport-multi.eps  parport-structure.eps
make[1]: Leaving directory `/usr/src/linux-2.4.0/Documentation/DocBook'
kgcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o scripts/split-include scripts/split-include.c
scripts/split-include include/linux/autoconf.h include/config
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6   -c -o init/main.o init/main.c
In file included from /usr/src/linux-2.4.0/include/linux/raid/md.h:51,
                 from init/main.c:25:
/usr/src/linux-2.4.0/include/linux/raid/md_k.h: In function `pers_to_level':
/usr/src/linux-2.4.0/include/linux/raid/md_k.h:39: warning: control reaches end of non-void function
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6  -DUTS_MACHINE='"i386"' -c -o init/version.o init/version.c
make CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6 " -C  kernel
make[1]: Entering directory `/usr/src/linux-2.4.0/kernel'
make all_targets
make[2]: Entering directory `/usr/src/linux-2.4.0/kernel'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -fno-omit-frame-pointer -c -o sched.o sched.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o dma.o dma.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o fork.o fork.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o exec_domain.o exec_domain.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o panic.o panic.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o printk.o printk.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o module.o module.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o exit.o exit.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o itimer.o itimer.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o info.o info.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o time.o time.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o softirq.o softirq.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o resource.o resource.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o sysctl.o sysctl.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o acct.o acct.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o capability.o capability.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o ptrace.o ptrace.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o timer.o timer.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o user.o user.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -DEXPORT_SYMTAB -c signal.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -DEXPORT_SYMTAB -c sys.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -DEXPORT_SYMTAB -c kmod.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -DEXPORT_SYMTAB -c context.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -c -o uid16.o uid16.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.0/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=k6    -DEXPORT_SYMTAB -c ksyms.c
In file included from /usr/src/linux-2.4.0/include/linux/fs.h:20gcc: Internal error: Segmentation fault (program cpp0)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [ksyms.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.0/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.0/kernel'
make: *** [_dir_kernel] Error 2
[root@babe linux-2.4.0]# ,
                 from /usr/src/linux-2.4.0/include/linux/capability.h:18,
                 from /usr/src/linux-2.4.0/include/linux/binfmts.h:6,
                 from /usr/src/linux-2.4.0/include/linux/sched.h:10,
                 from /usr/src/linux-2.4.0/include/linux/mm.h:5,
                 from /usr/src/linux-2.4.0/include/linux/slab.h:15,
                 from /usr/src/linux-2.4.0/include/linux/malloc.h:5,
                 from ksyms.c:14:
/usr/src/linux-2.4.0/include/linux/dcache.h:155: parse error at end of input
 
[root@babe linux-2.4.0]#
Comment 1 Jakub Jelinek 2001-01-20 04:30:13 EST

*** This bug has been marked as a duplicate of 24442 ***

Note You need to log in before you can comment on or make changes to this bug.