Bug 244412 - Evolution Hangs after several minutes
Evolution Hangs after several minutes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 10:31 EDT by Brian Wheeler
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.10.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:24:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Wheeler 2007-06-15 10:31:56 EDT
Description of problem:

After opening evolution it will run fine for a random number of minutes until it
becomes unresponsive.


Version-Release number of selected component (if applicable):

evolution-data-server-1.10.2-2.fc7
evolution-data-server-devel-1.10.2-2.fc7
evolution-devel-2.10.2-2.fc7
evolution-2.10.2-2.fc7
evolution-connector-2.10.2-2.fc7
evolution-webcal-2.10.0-1.fc7


How reproducible:

Seems like every time after several minutes

Steps to Reproduce:
1. fire up evolution
2. go about your business (or even ignore evolution)
3.
  
Actual results:

Hangs and must be killed using evolution --force-shutdown

Expected results:

No hang

Additional info:

The version I had installed previously 

(base install + updates of 

yum.log.1:Jun 05 13:37:37 Updated: evolution-devel.i386 2.10.1-4.fc7
yum.log.1:Jun 05 13:51:25 Updated: evolution-connector.i386 2.10.0-1.fc7

) 

worked as intended.  I have one IMAP account and one exchange account.
Comment 1 Brian Wheeler 2007-06-18 15:34:13 EDT
I updated again today and its still broken.  However, backing up to the
evolution-* packages which shipped with F7 seems to have resolved it.
Comment 2 Nick Stoughton 2007-06-29 13:12:30 EDT
I'm seeing regular hangs from evolution mail ... particularly when it regains
focus after running some other app.

This is on F7, with evolution 2.10.2 and all the latests updates applied
(evolution-2.10.2-2.fc7)

(gdb) thread apply all bt

Thread 4 (Thread -1285051504 (LWP 8423)):
#0  0x00b10402 in __kernel_vsyscall ()
#1  0x00e91b73 in poll () from /lib/libc.so.6
#2  0x00323633 in ?? () from /lib/libglib-2.0.so.0
#3  0x003239a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x00a765d4 in ?? () from /usr/lib/libnm_glib.so.0
#5  0x0033e49f in ?? () from /lib/libglib-2.0.so.0
#6  0x00d692fb in start_thread () from /lib/libpthread.so.0
#7  0x00e9b93e in clone () from /lib/libc.so.6

Thread 3 (Thread -1403774064 (LWP 8454)):
#0  0x00b10402 in __kernel_vsyscall ()
#1  0x00e91b73 in poll () from /lib/libc.so.6
#2  0x00323633 in ?? () from /lib/libglib-2.0.so.0
#3  0x003239a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x02e56510 in ?? () from /usr/lib/libORBit-2.so.0
#5  0x0033e49f in ?? () from /lib/libglib-2.0.so.0
#6  0x00d692fb in start_thread () from /lib/libpthread.so.0
#7  0x00e9b93e in clone () from /lib/libc.so.6

Thread 2 (Thread -1392632944 (LWP 8851)):
#0  0x00b10402 in __kernel_vsyscall ()
#1  0x00ea851e in __lll_mutex_lock_wait () from /lib/libc.so.6
#2  0x00e372b8 in _L_lock_14756 () from /lib/libc.so.6
#3  0x00e36574 in free () from /lib/libc.so.6
#4  0x003278c1 in g_free () from /lib/libglib-2.0.so.0
#5  0x00345325 in ?? () from /lib/libglib-2.0.so.0
#6  0x0033efc9 in ?? () from /lib/libglib-2.0.so.0
#7  0x00d68a1c in __nptl_deallocate_tsd () from /lib/libpthread.so.0
#8  0x00d69309 in start_thread () from /lib/libpthread.so.0
#9  0x00e9b93e in clone () from /lib/libc.so.6

Thread 1 (Thread -1209227552 (LWP 8383)):
#0  0x00b10402 in __kernel_vsyscall ()
#1  0x00ea851e in __lll_mutex_lock_wait () from /lib/libc.so.6
#2  0x00e36e68 in _L_lock_41 () from /lib/libc.so.6
#3  0x00e3056b in ptmalloc_lock_all () from /lib/libc.so.6
#4  0x00e5b502 in fork () from /lib/libc.so.6
#5  0x00d722c4 in fork () from /lib/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
#6  0x03478a22 in ?? () from /usr/lib/libgnomeui-2.so.0
#7  <signal handler called>
#8  0x00b10402 in __kernel_vsyscall ()
#9  0x00df3fa0 in raise () from /lib/libc.so.6
#10 0x00df58b1 in abort () from /lib/libc.so.6
#11 0x00e2aebb in __libc_message () from /lib/libc.so.6
#12 0x00e32f41 in _int_free () from /lib/libc.so.6
#13 0x00e36580 in free () from /lib/libc.so.6
#14 0x003278c1 in g_free () from /lib/libglib-2.0.so.0
#15 0x010c9555 in ?? () from /usr/lib/evolution/2.10/components/libevolution-mail.so
#16 0x010c902e in ?? () from /usr/lib/evolution/2.10/components/libevolution-mail.so
#17 0x0031e8c1 in ?? () from /lib/libglib-2.0.so.0
#18 0x00320622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x003235ff in ?? () from /lib/libglib-2.0.so.0
#20 0x003239a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x02f4a7e3 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x0805eb90 in main ()
#0  0x00b10402 in __kernel_vsyscall ()
(gdb) 

Comment 3 Matthew Barnes 2007-06-29 13:54:08 EDT
Please try upgrading to evolution-2.10.2-3.fc7, available now in Updates Testing.
Comment 4 Nick Stoughton 2007-07-02 11:21:47 EDT
evolution-2.10.2-3.fc7 appears to be far more stable!
Comment 5 Matthew Barnes 2007-07-02 12:02:01 EDT
Thanks for the confirmation; I'm requesting it be pushed to Updates.
Comment 6 Nick Stoughton 2007-07-02 14:05:27 EDT
There is a different problem that really appears to manifest itself in
evolution-2.10.2-3.fc7 (though I noticed some affects of this in previous
versions): the display is not updated correctly. Deleted messages are not
hidden, and new messages are not displayed without first changing to a different
imap folder and then back to inbox.

Since this is unrelated to this bug, I'll open a new bug on this. However, it
might make you pause on pushing this release to updates.
Comment 7 Milan Crha 2007-11-21 07:24:20 EST
Closing this bug because 2.10.2-3.fc7 is in updates for long time now. Thanks
for your help.

Note You need to log in before you can comment on or make changes to this bug.