Bug 24444 - RH7.0 installation wiped out my RH6.2 system
RH7.0 installation wiped out my RH6.2 system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-20 00:32 EST by Werner Puschitz
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-16 18:43:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Werner Puschitz 2001-01-20 00:32:13 EST
RH6.2 is installed on /dev/hda1    (3000MB)
Swapping space is on /dev/hda2  (256M)

Now I started to install RH7.0.
I choose "Server Installation - Web server" and I assigned /dev/hda3
(3000M) to "/".
After the installtion was done and I rebooted the server, "/" was on
/dev/hda3  *BUT* "/boot" was on /dev/hda1  !  
I did not assign "/boot" to /dev/hda1. My old RH6.2 system got wiped out.

Werner
Comment 1 Michael Fulbright 2001-01-24 11:44:01 EST
What were the orginal mount points/partitions used by 6.2?

Could you also tell me step by step what you did at each screen when you
installed 7.0?
Comment 2 Werner Puschitz 2001-01-24 23:15:41 EST
I went through the whole procedure again and I was not able to recreate the same
problem.
However, you will see that the first installation of 7.0 failed so that I had to
restart
all over again. I had the same problem when I lost my 6.2 system the first time.
I included the anaconda debug output. Please note that I _never_ assigned /boot
to /dev/hda1
by mistake. When I installed 7.0, I left /dev/hda1 untouched.


===
6.2
===

- Install Type:
  Server (I selected fdisk)

- I partitioned /dev/hda with fdisk

  Here is the output after 6.2 was up:

  [root@cmr3 /root]# fdisk -l

  Disk /dev/hda: 255 heads, 63 sectors, 1650 cylinders
  Units = cylinders of 16065 * 512 bytes

     Device Boot    Start       End    Blocks   Id  System
  /dev/hda1             1       383   3076416   83  Linux
  /dev/hda2           384       416    265072+  82  Linux swap
  [root@cmr3 /root]#

- Disk Druid:
  Assigned /dev/hda1 to "/"

  Here is the output after 6.2 was up:

  [root@cmr3 /root]# df
  Filesystem           1k-blocks      Used Available Use% Mounted on
  /dev/hda1              3028080    417456   2456804  15% /
  [root@cmr3 /root]#

- Network Configuration
  Activate on boot

- ...


===
7.0
===

- Install Type:
  Server

- I selected "Manually partition with fdisk"

- I added another partitions to /dev/hda with fdisk
  I created the primary partition /dev/hda3 with 3GB and I assigned "/" to it.
  I DID NOT assign any mount point to /dev/hda1 !

- Disk Druid:
  Assigned /dev/hda3 to "/"

- Network Configuration
  Activate on boot

- Package Group Selection:
  Web Server

  After I clicked Next for starting the installation I got the following error
message "hda3: Invalid argument"
  (The same thing happend when I installed 6.2 when it got wiped out).

  Here is the debug output:

    Traceback (innermost last):
      File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
        rc = self.todo.doInstall ()
      File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in
doInstall
        self.fstab.mountFilesystems (self.instPath)
      File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in
mountFilesystems
        raise SystemError, (errno, msg)
    SystemError: (22, 'Invalid argument')

    Local variables in innermost frame:
    size: 3076447
    fsystem: ext2
    self: <fstab.GuiFstab instance at 8495250>
    msg: Invalid argument
    doFormat: 1
    errno: 22
    device: hda3
    instPath: /mnt/sysimage
    mntpoint: /

    ToDo object:
    (itodo
    ToDo
    p1
    (dp2
    S'method'
    p3
    (iimage
    CdromInstallMethod
    p4
    (dp5
    S'progressWindow'
    p6

    <failed>


=======================================
Now I restarted all over again with 7.0
=======================================

- Install Type:
  Server

- I selected "Manually partition with fdisk"

- With fdisk I make sure that the partition still looks OK.

- DiskDruid:
  I assigned only /dev/hda3 to "/". I left /dev/hda1 unouched.

- Network Configuration
  Activate on boot

- Package Group Selection:
  Web Server

- ...

Here is the output after 7.0 was up:

[root@localhost /root]# fdisk -l /dev/hda

Disk /dev/hda: 255 heads, 63 sectors, 1650 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1       383   3076416   83  Linux
/dev/hda2           384       416    265072+  82  Linux swap
/dev/hda3           417       799   3076447+  83  Linux
[root@localhost /root]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda3              3028108    450712   2423576  16% /
[root@localhost /root]#

--------------------

BTW, why do I not have the possibility to say how I want to install LILO?
Anyway, after 7.0 was up, I reconfigured lilo to boot both RH versions.

Thanks
Werner
Comment 3 Brent Fox 2001-02-16 18:42:58 EST
This issue has been resolved with more error checking routines.
Comment 4 Werner Puschitz 2001-05-12 16:39:43 EDT
I just installed RH7.1 on another PC and I wondered why RH7.1 did not come
up after reboot. I found out that it happened again that Anaconda mounted
/boot on the wrong parition which I did NOT assign during the installation.

o During the installation I assigned /dev/hdb2 as /boot since I can't
  boot from hdd and that's what lilo.conf says:

  boot=/dev/hdb2   <---
  map=/boot/map
  install=/boot/boot.b
  prompt
  timeout=50
  message=/boot/message
  linear
  default=linux

  image=/boot/vmlinuz-2.4.2-2
        label=linux
        read-only
        root=/dev/hdd1   <--- /dev/hdd is the rest of

o But images were installed on /dev/hda3:

  Filesystem           1k-blocks      Used Available Use% Mounted on
  /dev/hdd1               520824     68244    426124  14% /
  /dev/hda3                65878      7616     54860  13% /boot  <---
  /dev/hdd10             7828088        88   7430348   1% /home
  /dev/hdd9              3102940        20   2945296   1% /opt
  /dev/hdd8               520824       208    494160   1% /tmp
  /dev/hdd5              4128320   2011448   1907084  52% /usr
  /dev/hdd6              2068620    102216   1861324   6% /usr/src
  /dev/hdd7              1034244     42968    938736   5% /var
  /dev/fd0                  1423      1033       391  73% /mnt/floppy
  /dev/hda2              2016520   1756124    157960  92% /xx

  /etc/mtab:
  /dev/hdd1 / ext2 rw 0 0
  none /proc proc rw 0 0
  /dev/hda3 /boot ext2 rw 0 0  <---
  /dev/hdd10 /home ext2 rw 0 0
  /dev/hdd9 /opt ext2 rw 0 0
  /dev/hdd8 /tmp ext2 rw 0 0
  /dev/hdd5 /usr ext2 rw 0 0
  /dev/hdd6 /usr/src ext2 rw 0 0
  /dev/hdd7 /var ext2 rw 0 0
  none /dev/pts devpts rw,gid=5,mode=620 0 0
  automount(pid649) /misc autofs rw,fd=5,pgrp=649,minproto=2,maxproto=3 0 0
  /dev/fd0 /mnt/floppy vfat rw,nosuid,nodev 0 0
  /dev/hda2 /xx ext2 rw 0 0

o Fortunatelly, this time the other OS didn't get wiped - you can still
  see the images of the other OS:

  # ls -alrtc
  --> RH6.2
  total 7620
  drwxr-xr-x    2 root     root        12288 Oct 28  2000 lost+found
  -rw-r--r--    1 root     root        11773 Oct 28  2000 module-info-2.2.16-22
  -rw-r--r--    1 root     root       200285 Oct 28  2000 System.map-2.2.16-22
  -rwxr-xr-x    1 root     root      1621492 Oct 28  2000 vmlinux-2.2.16-22
  -rw-r--r--    1 root     root       627392 Oct 28  2000 vmlinuz-2.2.16-22
  -rwxr-xr-x    1 root     root      1756599 Oct 28  2000
vmlinux-2.2.16-22enterprise
  -rw-r--r--    1 root     root       213782 Oct 28  2000
System.map-2.2.16-22enterprise
  -rw-r--r--    1 root     root       662413 Oct 28  2000
vmlinuz-2.2.16-22enterprise
  lrwxrwxrwx    1 root     root           27 Oct 28  2000 vmlinuz ->
vmlinuz-2.2.16-22enterprise
  lrwxrwxrwx    1 root     root           31 Oct 28  2000 module-info ->
module-info-2.2.16-22enterprise
  lrwxrwxrwx    1 root     root           15 Oct 28  2000 kernel.h ->
kernel.h-2.2.16
  -rw-r--r--    1 root     root     640 Oct 28  2000 os2_d.b
  -rw-r--r--    1 root     root        23108 Oct 28  2000 message
  -rw-r--r--    1 root     root          612 Oct 28  2000 chain.b
  -rw-r--r--    1 root     root         5824 Oct 28  2000 boot.b
  -rw-r--r--    1 root     root          512 Oct 28  2000 boot.0303
  -rw-r--r--    1 root     root          405 Jan 12 18:19 kernel.h-2.2.16
  --> RH7.1 (I don't know why it says Jan 13)
  -rw-r--r--    1 root     root       868255 Jan 13 15:58 vmlinuz-2.4c
  -rw-r--r--    1 root     root       426766 Jan 13 15:59 System.map-2.4c
  lrwxrwxrwx    1 root     root           20 Jan 13 22:05 System.map ->
System.map-2.2.16-22
  -rw-r--r--    1 root     root       867126 Jan 13 22:06 vmlinuz-2.4
  -rw-r--r--    1 root     root       426706 Jan 13 22:06 System.map-2.4
  -rw-------    1 root     root        20480 Jan 13 22:06 map
  drwxr-xr-x    3 root     root         1024 May 12 15:27 .
  drwxr-xr-x   28 root     root         4096 May 12 16:12 ..


  /etc/fstab:
  LABEL=/1                /                       ext2    defaults        1 1
  LABEL=/boot             /boot                   ext2    defaults        1 2
  LABEL=/home             /home                   ext2    defaults        1 2
  /dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
  LABEL=/opt              /opt                    ext2    defaults        1 2
  LABEL=/tmp              /tmp                    ext2    defaults        1 2
  LABEL=/usr              /usr                    ext2    defaults        1 2
  LABEL=/usr/src          /usr/src                ext2    defaults        1 2
  LABEL=/var              /var                    ext2    defaults        1 2
  none                    /proc                   proc    defaults        0 0
  none                    /dev/pts                devpts  gid=5,mode=620  0 0
  /dev/hda6               swap                    swap    defaults        0 0
  /dev/hdb8               swap                    swap    defaults        0 0
  /dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro
0 0

Werner

Comment 5 Werner Puschitz 2001-05-12 16:53:38 EDT
I guess, I messed up here, vmlinuz-2.4c is not Seawolf.
The images were installed on /dev/hdb2 but after the RH7.1 installation,
/dev/hda3 was assigned to /boot and not /dev/hdb2.

Werner

Note You need to log in before you can comment on or make changes to this bug.