Bug 244471 - Files Tab and Changelog Tab are empty in Updates and Av
Files Tab and Changelog Tab are empty in Updates and Av
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 17:46 EDT by Michael Möllney
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 06:25:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Möllney 2007-06-15 17:46:18 EDT
Description of problem:
After Updating from FC6 to F7 the Files Tab and the Changelog Tab are empty for
the package collections: update and available.
Before I had plenty of info in these Tabs under Package View.
I can't find a place in yumex how to switch on the filling of this Tabs.

Version-Release number of selected component (if applicable):
yumex-1.9.8-2.0.fc7 German Language in Menue but Englisch in Windows.

How reproducible:
Just Start Yumex and wait for the package view to be filled.
  
Actual results:
Files Tab and Changelog Tab is empty for every package in updates and available.

Expected results:
Files Tab and Changelog Tab should contain information before I install it.
Comment 1 Tim Lauridsen 2007-06-16 03:20:58 EDT
You are right the Changelog & Files are only populated for installed packages,
because it need to a lot of extra MB of metadata to show it, and most people
don't want to wait for the extra metadata to load.
yumex 1.2.x had an option for the user to select if i wanted to download, the
extra metadata.
I am not sure how to handle it in yumex 1.9.x, i could add the same or just hide
the tabs for available packages.
Comment 2 Michael Möllney 2007-06-18 11:53:06 EDT
(In reply to comment #1)
> You are right the Changelog & Files are only populated for installed packages,
> because it need to a lot of extra MB of metadata to show it, and most people
> don't want to wait for the extra metadata to load.
> yumex 1.2.x had an option for the user to select if i wanted to download, the
> extra metadata.

The Files Tab was helpful for me from time to time. Sometimes a software package
is ditributed over some rpm packeges: qt4, qt4-develp, qt- .... before
installing every package it was nice to have a look which file is in which package.

Maybe for this task a feature like: look for package containing file: xxxx

> I am not sure how to handle it in yumex 1.9.x, i could add the same or just hide
> the tabs for available packages.

I would prefer to have the option to load the files and changelg data,
Maybe there could be a button to get the data on request for the current
selected package... kind of lazy loading: just call for the tab contents when
packacge was selected....
Comment 3 Tim Lauridsen 2007-06-22 06:25:49 EDT
I have added a '--filelist' and '--changelog' commandline to make yumex load
extra metadata and show filelist/changelog for available packages, i also have
added a 'filelist=' and a 'changelog=' option to /etc/yumex.conf to enable it
permantly.
I dont have added a gui way to enable it, because yumex is currently in string
freeze, for the translator to translate it to native languages.
It will be added later after yumex-2.0 is released.
Comment 4 Michael Möllney 2007-06-22 14:35:38 EDT
Nice to hear.
Updated to yumex 1.9.9, but this is still missing this feature. Guess I have to
wait for 2.0.

Will it be possible to look for files in the filelist via the filter/search line
in the package view, too?

Maybe it is a good idea, to make the switches 'filelist' and 'changelog' profile
aware...? Wasn't it like this?

So have profile: All_With_Changelog, All_Without_Changelog,
Just_Updates_With_Changelog, ...

Comment 5 Tim Lauridsen 2007-06-23 02:54:57 EDT
(In reply to comment #4)
> Nice to hear.
> Updated to yumex 1.9.9, but this is still missing this feature. Guess I have to
> wait for 2.0.

I will be available in 1.9.10, i will push it in the next couple of days.
you can test it by checking out the SVN trunk version.
Instructions here:
http://www.yum-extender.org/wiki/Yumex/Development#head-73181305a483e5dc153c264d062ef16f403961d3

> 
> Will it be possible to look for files in the filelist via the filter/search line
> in the package view, too?

Not, at the moment, but a nice idea, i will put it on the todo list.

> 
> Maybe it is a good idea, to make the switches 'filelist' and 'changelog' profile
> aware...? Wasn't it like this?
> 
> So have profile: All_With_Changelog, All_Without_Changelog,
> Just_Updates_With_Changelog, ...
> 
> 
Nice idea, put it on the TODO list.

Note You need to log in before you can comment on or make changes to this bug.