Bug 244569 - Non working spellcheck for Bulgarian due to encoding error.
Non working spellcheck for Bulgarian due to encoding error.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: aspell-bg (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 09:34 EDT by Alexander Shopov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.50-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 12:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Shopov 2007-06-17 09:34:03 EDT
Description of problem:
When I do:
     aspell -l bg -c test.txt
I get the message:
     Error: /usr/lib/aspell-0.60/bulgarian.kbd:4: The string "w�" is invalid.
Invalid UTF-8 sequence at position 2.

There seems to be a mismatch between the actual encoding provided by the
Bulgarian resource files and the one expected by aspell.

From the error message it would seem that /usr/lib/aspell-0.60/bulgarian.kbd
should be in UTF-8, actually - it is in CP1251.

The file: /usr/lib/aspell-0.60/bg.dat contains the line: 
      charset cp1251
which probably means that the data should be in CP1251

Version-Release number of selected component (if applicable):
aspell-bg-0.50-14.fc7
aspell-0.60.5-3.fc7


How reproducible:
Always

Steps to Reproduce:
Apart from the command 
aspell -l bg -c test.txt
I also cannot set gedit (for example) to do Bulgarian spellcheck
  
Additional info:

When I converted /usr/lib/aspell-0.60/bulgarian.kbd from cp1251 to UTF-8 -
things started working again and I have a working Bulgarian spellcheck.
Comment 1 Ivana Varekova 2007-06-18 03:59:04 EDT
Fixed in aspell-bg-0.50-15.fc7.

*** This bug has been marked as a duplicate of 238426 ***
Comment 2 Fedora Update System 2007-06-18 12:40:29 EDT
aspell-bg-0.50-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Doncho N. Gunchev 2007-06-21 18:21:05 EDT
/usr/lib/aspell-0.60/bg.dat still contains 'cp1251'. Is this a problem?

Note You need to log in before you can comment on or make changes to this bug.