Bug 244571 - `yum info all' exits with UnicodeEncodeError
Summary: `yum info all' exits with UnicodeEncodeError
Status: CLOSED DUPLICATE of bug 244080
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 7
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-17 14:11 UTC by Cristian Ciupitu
Modified: 2014-01-21 22:58 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-06-18 21:17:18 UTC


Attachments (Terms of Use)

Description Cristian Ciupitu 2007-06-17 14:11:23 UTC
When I run `yum info all' it exits with an UnicodeEncodeError at the aterm
package:

# yum info all
Loading "installonlyn" plugin
Installed Packages
Name   : ConsoleKit
........
Name   : aterm
Arch   : i386
Version: 1.0.0
Release: 7.fc7
Size   : 117 k
Repo   : fedora
Summary: Afterstep XVT, VT102 emulator for the X Window system

Traceback (most recent call last):  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 264, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 165, in doCommand
    base.listPkgs(ypl.available, 'Available Packages', basecmd)
  File "/usr/share/yum-cli/output.py", line 102, in listPkgs
    self.infoOutput(pkg)
  File "/usr/share/yum-cli/output.py", line 73, in infoOutput
    print _("Description:\n%s") % pkg.description
UnicodeEncodeError: 'ascii' codec can't encode character u'\xb4' in position
109: ordinal not in range(128)


Version-Release number of selected component(s):
 yum-3.2.0-1.fc7.noarch.rpm
 yum-metadata-parser-1.1.0-2.fc7.i386.rpm
 yum-updatesd-3.2.0-1.fc7.noarch.rpm


How reproducible:
    Everytime (on my machine)


Steps to Reproduce:
    Relevant environmental variables:
LANG=en_US.UTF-8
    no LC* variables are set.


Other information that could be useful:
      `yum info aterm' works

# yum info aterm
Loading "installonlyn" plugin
Available Packages
Name   : aterm
Arch   : i386
Version: 1.0.0
Release: 7.fc7
Size   : 117 k
Repo   : fedora
Summary: Afterstep XVT, VT102 emulator for the X Window system
Description:
aterm, version 1.00 is a colour vt102 terminal emulator, based on
rxvt 2.4.8 with Alfredo Kojima´s additions of fast transparency,
intended as an xterm(1) replacement for users who do not require fea-
tures such as Tektronix 4014 emulation and toolkit-style configurabil-
ity. As a result, aterm uses much less swap space -- a significant
advantage on a machine serving many X sessions.

#

Comment 1 Cristian Ciupitu 2007-06-17 14:43:31 UTC
   The following command works fine:
yum --exclude aterm --exclude ballz --exclude checkpolicy --exclude ctrlproxy
--exclude cups-devel --exclude cups-lpd --exclude curry --exclude dates
--exclude exim-clamav --exclude inkscape --exclude ipw2100-firmware --exclude
ipw2200-firmware --exclude iwlwifi-firmware --exclude jbigkit-libs --exclude
kompose --exclude opencv --exclude prelude-lml --exclude regexxer --exclude
selinux-doc --exclude wv2 --exclude xfce4-places-plugin --exclude zzuf info all

Comment 2 Jeremy Katz 2007-06-18 21:17:18 UTC

*** This bug has been marked as a duplicate of 244080 ***


Note You need to log in before you can comment on or make changes to this bug.