Bug 244591 - yum-updatesd leaks memory
yum-updatesd leaks memory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 16:25 EDT by Richard Körber
Modified: 2014-01-21 17:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 15:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Körber 2007-06-17 16:25:05 EDT
Description of problem:
After running for some hours, yum-updatesd consumes a large amount of memory.

Version-Release number of selected component (if applicable):
yum-updatesd-3.2.0-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Enable yum-updatesd (enabled by default)
2. Wait for some hours
3. Start 'top' and press 'M' to sort by memory usage
  
Actual results:
After a few hours, yum-updatesd hogs about 109m (VIRT) and 66m (RES) of memory
on my system. When I restart yum-updatesd, it will again use a lot of memory
after some time.

Expected results:
yum-updatesd permanently allocates only a small amount of memory.

Additional info:
Right after start yum-updatesd does not need much memory, so it seems to be a
memory leak. I was able to confirm this bug on a second F7 installation.
Comment 1 Alessandro 2007-06-22 09:53:36 EDT
I confirm this leak... yum-updatesd eat 60 mega of ram after some minutes... One
question: In the previous fedora release (core 6 for example) how much memory
ate yum-updatesd?
Comment 2 Gian Paolo Mureddu 2007-06-27 04:56:45 EDT
I can also confirm this on F7, never "quantified" the amount it took on Core 6
as I was quick to disable it (basically due to the resource hog it was in Core 6
and the conflict it posed with Pirut and Yum CLI when it was silently fetching
repo data).

On my system (x86_64) about 2:30 hours of up time, yum-updatesd was using more
than 200Mb of system memory.
Comment 3 Michael Cochran 2007-07-17 10:14:04 EDT
I also confirm this, after about 30 mins yum-updatesd was using nearly 500Mb of
memory. As long as it was running, my system would not run a full day without a
restart.
Comment 4 Seth Vidal 2007-08-03 15:57:45 EDT
Please test yum-updatesd from rawhide. 

Note You need to log in before you can comment on or make changes to this bug.