Bug 244600 - vncviewer in vnc-4.1.2-18.fc7 does not pass ctrl-key combination
Summary: vncviewer in vnc-4.1.2-18.fc7 does not pass ctrl-key combination
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-17 23:24 UTC by Kevin Street
Modified: 2007-12-19 16:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 16:02:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Street 2007-06-17 23:24:39 UTC
Description of problem:
vncviewer in vnc-4.1.2-18.fc7 does not pass ctrl-key combinations eg. ctrl-u in
terminal window.  Installing back level vnc-4.1.2-16.fc7 on client works as
expected.

Version-Release number of selected component (if applicable):
vnc-4.1.2-18.fc7

How reproducible:
always when pressing ctrl plus character

Steps to Reproduce:
1.open vncviewer to linux vnc server
2.open a gnome-terminal in vncviewer window
3.type stuff on command line
4.press ctrl-u (expecting it to delete back to beginning of line)
5.see 'u' appear on line instead

  
Actual results:
ctrl-char passes char to server

Expected results:
ctrl-char passes ctrl-char to server

Additional info:

Comment 1 Adam Tkac 2007-06-18 08:14:57 UTC
Looks like same bug as #188169 . I removed patch in vnc-4.1.2-17.fc7 . Let me
make next round of thinking about this issue and try fix problems whose this
patch brough.

Adam

Comment 2 Adam Tkac 2007-06-18 11:50:51 UTC
Main problem is that "grab pointer" feature in control-center grabs ctrl key. So
vncviewer doesn't get "KeyPress" event and can't handle it correctly.
Reassigning to control-center for investigation what could be done.

A

Comment 3 Kevin Street 2007-06-18 17:48:10 UTC
Yes, un-checking "Highlight the pointer when you press Ctrl" in
System->Preferences->Hardware->Mouse lets vncviewer in vnc-4.1.2-18.fc7 work
properly.

Comment 4 Pierre VALIRON 2007-11-13 20:43:01 UTC
I encountered the same bug after upgrading my laptop to FC8. 
Installing back level vnc-4.1.2-16.fc7 solved the problem as above. 
I suggest to stick to version 4.1.2-16 in the fedora repository for FC7 and FC8
until the bug is fixed.  

Comment 5 Bastien Nocera 2007-12-19 16:02:02 UTC
The feature doesn't exist anymore in F8.


Note You need to log in before you can comment on or make changes to this bug.