Bug 244610 - fence_apc in RHEL4U5 can not work with APC 7921
fence_apc in RHEL4U5 can not work with APC 7921
Status: CLOSED DUPLICATE of bug 241102
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 23:03 EDT by Qian Shen
Modified: 2015-10-25 21:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 06:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Shen 2007-06-17 23:03:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

When I use a APC 7921 as fence device, the fence_apc will report error like
following.

Jun 15 19:05:50 beijslxtsc14 fenced[6539]: agent "fence_apc" reports
: Traceback (most recent call last):   File "/sbin/fence_apc", line 
798, in ?     main()   File "/sbin/fence_apc", line 285, in main    
 do_login(sock)   File "/sbin/fence_apc", line 440, in do_login     
i, mo, txt = sock.expect(regex_list, TELNET_TIMEOUT) 
Jun 15 19:05:50 beijslxtsc14 fenced[6539]: agent "fence_apc" reports
:   File "/usr/lib64/python2.3/telnetlib.py", line 620, in expect   
  text = self.read_very_lazy()   File "/usr/lib64/python2.3/telnetli
b.py", line 400, in read_very_lazy     raise EOFError, 'telnet conne
ction closed' EOFError: telnet connection closed 
Jun 15 19:05:50 beijslxtsc14 fenced[6539]: fence "beijslxtsc19" fail
ed


Steps to Reproduce:
1. setup a RHEL4U5 cluster.
2. fence_apc -a ip -l -p 
  
Actual results:


Expected results:


Additional info:

fence_apc in RHCS4U4 can work well.
Comment 1 Bryn M. Reeves 2007-11-23 06:02:30 EST
Demangled backtrace:

Jun 15 19:05:50 beijslxtsc14 fenced[6539]: agent "fence_apc" reports: 
Traceback (most recent call last):   
   File "/sbin/fence_apc", line 798, in ?     
     main()   
   File "/sbin/fence_apc", line 285, in main
     do_login(sock)   
   File "/sbin/fence_apc", line 440, in do_login
     i, mo, txt = sock.expect(regex_list, TELNET_TIMEOUT)
Jun 15 19:05:50 beijslxtsc14 fenced[6539]: agent "fence_apc" reports:   
   File "/usr/lib64/python2.3/telnetlib.py", line 620, in expect
     text = self.read_very_lazy()   
   File "/usr/lib64/python2.3/telnetlib.py", line 400, in read_very_lazy     
     raise EOFError, 'telnet connection closed' 
EOFError: telnet connection closed 
Jun 15 19:05:50 beijslxtsc14 fenced[6539]: fence "beijslxtsc19" failed
Comment 2 Bryn M. Reeves 2007-11-23 06:02:47 EST

*** This bug has been marked as a duplicate of 241102 ***

Note You need to log in before you can comment on or make changes to this bug.