Bug 244612 - Installing OS fails on ATI/AMD SB700 chipset with combined mode
Installing OS fails on ATI/AMD SB700 chipset with combined mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 244613 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 23:44 EDT by Shane Huang
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version: Fedora 8 Test 2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 04:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Huang 2007-06-17 23:44:15 EDT
+++ This bug was initially created as a clone of Bug #244011 +++

Description of problem:
Set SATA mode as Combined mode, installing OS fails on ATI SB700 chipset

Version-Release number of selected component (if applicable):
2.6.18

How reproducible:
always

Steps to Reproduce:
1.Set Onchip SATA to be "Combined" mode in System BIOS.
2.Start installation from ODD.

  
Actual results:
Cannot find any hard disk.

Expected results:
Hard disk should be detected.

Additional info:
This patch will be included in the linux kernel from version 2.6.22


-- Additional comment from henry.su@amd.com on 2007-06-13 07:19 EST --
Created an attachment (id=156863)
the combined mode patched for this issue

this patch fixs this issue and is accepted by kernel.org.

-- Additional comment from bnagendr@redhat.com on 2007-06-15 12:32 EST --
Patch posted to RHML on Jun 15.

-- Additional comment from pm-rhel@redhat.com on 2007-06-15 13:48 EST --
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 1 Chuck Ebbert 2007-06-18 21:24:20 EDT
Please submit to the linux stable team for kernel 2.6.21.

Shane, submit this patch to the -stable linux kernel team. This will save
both of us some work if you do it this way. See the file:

   Documentation/stable_kernel_rules.txt

in the linux source. We automatically update to the latest stable release for
Fedora kernels.
Comment 2 Shane Huang 2007-06-18 22:44:25 EDT
We have submitted the patch to the corresponding driver/kernel maintainer,
it has been accepted and will appear on stable kernel from 2.6.22
So when next Fedora distribution(FC8) use latest stable kernel(2.6.22 or 
later),
it should include the patch.

I create this bug item so that we can trace this issue.
And I hope you can confirm that before FC8' release if possible. Thanks
Comment 3 Christopher Brown 2007-09-17 07:00:03 EDT
Hello Shane,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

There hasn't been much activity on this bug for a while. Has the patch been
accepted upstream and/or does the latest kernel still suffer this problem?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 4 Christopher Brown 2007-09-17 07:03:24 EDT
*** Bug 244613 has been marked as a duplicate of this bug. ***
Comment 5 Shane Huang 2007-09-19 23:37:25 EDT
The patch has been accepted and appears from linux-2.6.22.
Upstream commit:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=823777181b4c0200923dcb026efa5b37f55c0ecf

So you can close this bug because I find FC8 Test 2 contains this patch.

Note You need to log in before you can comment on or make changes to this bug.