Bug 244613 - Cannot find IDE device with ATI/AMD SB700
Cannot find IDE device with ATI/AMD SB700
Status: CLOSED DUPLICATE of bug 244612
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-06-17 23:51 EDT by Shane Huang
Modified: 2007-11-30 17:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-17 07:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Shane Huang 2007-06-17 23:51:07 EDT
+++ This bug was initially created as a clone of Bug #244150 +++

Description of problem:Install OS with native IDE mode, cannot find the IDE 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Set onchip SATA mode as native IDE mode in system BIOS
2.install the OS from ODD

Actual results:
Cannot find any hard disk device

Expected results:
Hard disk should be detected

Additional info:
This patch will be included in the linux kernel from version 2.6.22

-- Additional comment from henry.su@amd.com on 2007-06-14 02:37 EST --
ATI/AMD SB700 is a new south bridge chipset, this chipset is not fully 
supported for lack of the controller device IDs.

The attached patch accepted by kernel.org fix this issue.

-- Additional comment from henry.su@amd.com on 2007-06-14 02:38 EST --
Created an attachment (id=156960)
add the IDE device ID

-- Additional comment from henry.su@amd.com on 2007-06-14 04:05 EST --
the following patch fix this issue:
diff -Nur linux- linux-
--- linux- 2007-05-16 13:28:54.405386000 
+++ linux-      2007-05-16 13:45:29.936636000 
@@ -371,6 +371,9 @@
 #define PCI_DEVICE_ID_ATI_IXP600_SRAID 0x4381
 #define PCI_DEVICE_ID_ATI_IXP600_SMBUS 0x4385
 #define PCI_DEVICE_ID_ATI_IXP600_IDE   0x438c
+#define PCI_DEVICE_ID_ATI_IXP700_IDE   0x439c

 #define PCI_VENDOR_ID_VLSI             0x1004
 #define PCI_DEVICE_ID_VLSI_82C592      0x0005

diff -Nur linux- linux-
--- linux-       2007-05-16 
13:27:49.764761000 +0800
+++ linux-    2007-05-16 13:37:47.014761000 
@@ -283,6 +283,7 @@

        { },

diff -Nur linux- linux-
--- linux-        2007-05-16 
13:27:53.671011000 +0800
+++ linux-     2007-05-16 13:43:51.952261000 
@@ -353,6 +353,7 @@
PCI_ANY_ID, 0, 0, 0},
PCI_ANY_ID, 0, 0, 0},
PCI_ANY_ID, 0, 0, 1},
PCI_ANY_ID, 0, 0, 1},
        { 0, },
 MODULE_DEVICE_TABLE(pci, atiixp_pci_tbl);

-- Additional comment from alan@redhat.com on 2007-06-14 05:39 EST --
Looks ok to me once its upstream

-- Additional comment from bnagendr@redhat.com on 2007-06-15 08:58 EST --
Can this be included in R5.1?

-- Additional comment from prarit@redhat.com on 2007-06-15 09:16 EST --
(In reply to comment #5)
> Can this be included in R5.1?

Unlikely -- this is a new feature request, IMO.


-- Additional comment from bnagendr@redhat.com on 2007-06-15 12:31 EST --
Patch posted to RHML on Jun 15.

-- Additional comment from pm-rhel@redhat.com on 2007-06-15 13:26 EST --
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 1 Chuck Ebbert 2007-06-18 21:22:22 EDT
Shane, submit this patch to the -stable linux kernel team. This will save
both of us some work if you do it this way. See the file:


in the linux source. We automatically update to the latest stable release for
Fedora kernels.

Comment 2 Shane Huang 2007-06-18 22:48:19 EDT
We have submitted the patch to the corresponding driver/kernel maintainer,
it has been accepted and will appear on stable kernel from 2.6.22
So when next Fedora distribution(FC8) use latest stable kernel(2.6.22 or 
later), it should include the patch.

I create this bug item so that we can trace this issue.
And I hope you can confirm that before FC8' release if possible. Thanks
Comment 3 Christopher Brown 2007-09-17 07:03:23 EDT

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.


This bug appears to be a dupe of bug 244612 so I am closing it. If I have erred,
please accept my profuse apologies and re-open and I will attempt to assist in
its resolution.


*** This bug has been marked as a duplicate of 244612 ***
Comment 4 Shane Huang 2007-09-19 23:41:22 EDT
The patch has been accepted and appears from linux-2.6.22.

So you can close this bug because I find FC8 Test 2 contains this patch.

Note You need to log in before you can comment on or make changes to this bug.