Bug 244619 - evolution crashing
evolution crashing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 00:55 EDT by Stewart Hardie
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: evolution-2.10.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 12:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
back trace of evo crash (10.92 KB, application/octet-stream)
2007-06-28 20:12 EDT, Stewart Hardie
no flags Details

  None (edit)
Description Stewart Hardie 2007-06-18 00:55:30 EDT
Description of problem:
Using evolution.i386-2.10.2-2.fc7, have previously set up an IMAP account. When
moving some emails from one IMAP folder to another, the following error messages
occur in the terminal window and evolution needs to be killed.

--------------------------------------
[stewart@ballistix ~]$ evolution
CalDAV Eplugin starting up ...
evolution-shell-Message: Killing old version of evolution-data-server...
** (evolution:4278): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4278): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
(evolution:4278): e-data-server-DEBUG: Loading categories from
"/home/stewart/.evolution/categories.xml"
(evolution:4278): e-data-server-DEBUG: Loaded 17 categories

(evolution:4278): e-data-server-CRITICAL **: e_categories_get_icon_file_for:
assertion `cat_info != NULL' failed

(evolution:4278): e-data-server-CRITICAL **: e_categories_get_icon_file_for:
assertion `cat_info != NULL' failed

*** glibc detected *** evolution: free(): invalid pointer: 0x09463130 ***
======= Backtrace: =========
/lib/libc.so.6[0x469bdf41]
/lib/libc.so.6(cfree+0x90)[0x469c1580]
/lib/libglib-2.0.so.0(g_free+0x31)[0x46dd58c1]
/usr/lib/evolution/2.10/components/libevolution-mail.so[0x2af555]
/usr/lib/evolution/2.10/components/libevolution-mail.so[0x2af02e]
/lib/libglib-2.0.so.0[0x46dcc8c1]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x182)[0x46dce622]
/lib/libglib-2.0.so.0[0x46dd15ff]
/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9)[0x46dd19a9]
/usr/lib/libbonobo-2.so.0(bonobo_main+0x63)[0x460947e3]
evolution(main+0x380)[0x805eb90]
/lib/libc.so.6(__libc_start_main+0xe0)[0x4696bf70]
evolution[0x80506b1]
======= Memory map: ========
00110000-00166000 r-xp 00000000 08:12 3277023   
/usr/lib/libcamel-provider-1.2.so.10.0.0
00166000-00168000 rwxp 00055000 08:12 3277023   
/usr/lib/libcamel-provider-1.2.so.10.0.0
00168000-00172000 r-xp 00000000 08:12 31326249   /lib/libnss_files-2.6.so
00172000-00173000 r-xp 00009000 08:12 31326249   /lib/libnss_files-2.6.so
00173000-00174000 rwxp 0000a000 08:12 31326249   /lib/libnss_files-2.6.so
00174000-00175000 r-xp 00000000 08:12 39583928   /usr/lib/gconv/ISO8859-1.so
00175000-00177000 rwxp 00000000 08:12 39583928   /usr/lib/gconv/ISO8859-1.so
00177000-0017d000 r-xp 00000000 08:12 45973519  
/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
0017d000-0017e000 rwxp 00005000 08:12 45973519  
/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
0017e000-0017f000 r-xp 00000000 08:12 20840471  
/usr/lib/evolution/2.10/plugins/liborg-gnome-new-mail-notify.so
0017f000-00180000 rwxp 00000000 08:12 20840471  
/usr/lib/evolution/2.10/plugins/liborg-gnome-new-mail-notify.so
00180000-00181000 r-xp 00180000 00:00 0          [vdso]
00181000-001fe000 r-xp 00000000 08:12 19070995  
/usr/lib/evolution/2.10/libetable.so.0.0.0
001fe000-00201000 rwxp 0007c000 08:12 19070995  
/usr/lib/evolution/2.10/libetable.so.0.0.0
00201000-0022b000 r-xp 00000000 08:12 3277060   
/usr/lib/libedataserverui-1.2.so.8.0.1
0022b000-0022c000 rwxp 00029000 08:12 3277060   
/usr/lib/libedataserverui-1.2.so.8.0.1
0022c000-002fd000 r-xp 00000000 08:12 19103747  
/usr/lib/evolution/2.10/components/libevolution-mail.so
002fd000-00305000 rwxp 000d0000 08:12 19103747  
/usr/lib/evolution/2.10/components/libevolution-mail.so
00305000-00306000 rwxp 00305000 00:00 0 
00306000-00316000 r-xp 00000000 08:12 19071021  
/usr/lib/evolution/2.10/libmenus.so.0.0.0
00316000-00317000 rwxp 0000f000 08:12 19071021  
/usr/lib/evolution/2.10/libmenus.so.0.0.0
00317000-0031c000 r-xp 00000000 08:12 19071011  
/usr/lib/evolution/2.10/libevolution-calendar-importers.so.0.0.0
0031c000-0031d000 rwxp 00004000 08:12 19071011  
/usr/lib/evolution/2.10/libevolution-calendar-importers.so.0.0.0
0031d000-0031f000 r-xp 00000000 08:12 20840458  
/usr/lib/evolution/2.10/plugins/liborg-gnome-evolution-caldav.so
0031f000-00320000 rwxp 00002000 08:12 20840458  
/usr/lib/evolution/2.10/plugins/liborg-gnome-evolution-caldav.so
00321000-00353000 r-xp 00000000 08:12 19071001  
/usr/lib/evolution/2.10/libeutil.so.0.0.0
00353000-00355000 rwxp 00032000 08:12 19071001  
/usr/lib/evolution/2.10/libeutil.so.0.0.0
00355000-00367000 r-xp 00000000 08:12 19071009  
/usr/lib/evolution/2.10/libevolution-calendar-a11y.so.0.0.0
00367000-00368000 rwxp 00012000 08:12 19071009  
/usr/lib/evolution/2.10/libevolution-calendar-a11y.so.0.0.0
00368000-0036d000 r-xp 00000000 08:12 19070987  
/usr/lib/evolution/2.10/libefilterbar.so.0.0.0
0036d000-0036e000 rwxp 00005000 08:12 19070987  
/usr/lib/evolution/2.10/libefilterbar.so.0.0.0
0036e000-00373000 r-xp 00000000 08:12 19071005  
/usr/lib/evolution/2.10/libevolution-addressbook-a11y.so.0.0.0
00373000-00374000 rwxp 00004000 08:12 19071005  
/usr/lib/evolution/2.10/libevolution-addressbook-a11y.so.0.0.0
00375000-003a7000 r-xp 00000000 08:12 3277033    /usr/lib/libebook-1.2.so.9.0.1
003a7000-003ab000 rwxp 00031000 08:12 3277033    /usr/lib/libebook-1.2.so.9.0.1
003ab000-004d9000 r-xp 00000000 08:12 39555151   /usr/lib/libxml2.so.2.6.29
004d9000-004de000 rwxp 0012d000 08:12 39555151   /usr/lib/libxml2.so.2.6.29
004de000-004df000 rwxp 004de000 00:00 0 
004df000-004f4000 r-xp 00000000 08:12 19071019  
/usr/lib/evolution/2.10/libfilter.so.0.0.0
004f4000-004f5000 rwxp 00015000 08:12 19071019  
/usr/lib/evolution/2.10/libfilter.so.0.0.0
004f5000-004f8000 r-xp 00000000 08:12 20840459  
/usr/lib/evolution/2.10/plugins/liborg-gnome-evolution-hula-account-setup.so
004f8000-004f9000 rwxp 00003000 08:12 20840459  
/usr/lib/evolution/2.10/plugins/liborg-gnome-evolution-hula-account-setup.so
004f9000-0053a000 r-xp 00000000 08:12 19103745  
/usr/lib/evolution/2.10/components/libevolution-addressbook.so
0053a000-0053d000 rwxp 00041000 08:12 19103745  
/usr/lib/evolution/2.10/components/libevolution-addressbook.so
0053d000-00545000 r-xp 00000000 08:12 19071007  
/usr/lib/evolution/2.10/libevolution-addressbook-importers.so.0.0.0
00545000-00546000 rwxp 00008000 08:12 19071007  
/usr/lib/evolution/2.10/libevolution-addressbook-importers.so.0.0.0
00546000-00553000 r-xp 00000000 08:12 3276832    /usr/lib/liblber-2.3.so.0.2.22
00553000-00554000 rwxp 0000c000 08:12 3276832    /usr/lib/liblber-2.3.so.0.2.22
00554000-00558000 r-xp 00000000 08:12 19070999  
/usr/lib/evolution/2.10/libetimezonedialog.so.0.0.0
00558000-00559000 rwxp 00003000 08:12 19070999  
/usr/lib/evolution/2.10/libetimezonedialog.so.0.0.0
00559000-00677000 r-xp 00000000 08:12 19103746  
/usr/lib/evolution/2.10/components/libevolution-calendar.so
00677000-0067f000 rwxp 0011d000 08:12 19103746  
/usr/lib/evolution/2.10/components/libevolution-calendar.so
0067f000-00680000 rwxp 0067f000 00:00 0 
00680000-00702000 r-xp 00000000 08:12 3277064   
/usr/lib/libexchange-storage-1.2.so.3.0.0
00702000-00705000 rwxp 00082000 08:12 3277064   
/usr/lib/libexchange-storage-1.2.so.3.0.0
00705000-0077c000 r-xp 00000000 08:12 3276965    /usr/lib/libgnutls.so.13.0.10
0077c000-00782000 rwxp 00076000 08:12 3276965    /usr/lib/libgnutls.so.13.0.10
00782000-007d5000 r-xp 00000000 08:12 3276964    /usr/lib/libgcrypt.so.11.2.3
007d5000-007d7000 rwxp 00053000 08:12 3276964    /usr/lib/libgcrypt.so.11.2.3
007d7000-007fc000 r-xp 00000000 08:12 3277062   
/usr/lib/libegroupwise-1.2.so.13.0.0
007fc000-007fd000 rwxp 00025000 08:12 3277062   
/usr/lib/libegroupwise-1.2.so.13.0.0
007fd000-00819000 r-xp 00000000 08:12 45547523  
/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so
00819000-0081a000 rwxp 0001c000 08:12 45547523  
/usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so
0081a000-0081e000 r-xp 00000000 08:12 45973512  
/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
0081e000-0081f000 rwxp 00003000 08:12 45973512  
/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
0081f000-00859000 r-xp 00000000 08:12 39555248   /usr/lib/libfreebl3.so
00859000-0085a000 rwxp 0003a000 08:12 39555248   /usr/lib/libfreebl3.so
0085a000-0085d000 r-xp 00000000 08:12 20840461  
/usr/lib/evolution/2.10/plugins/liborg-gnome-evolution-startup-wizard.so
0085d000-0085e000 rwxp 00002000 08:12 20840461  
/usr/lib/evolution/2.10/plugins/liborg-gnome-evolution-startup-wizard.so
0085e000-00878000 r-xp 00000000 08:12 40272190  
/usr/lib/evolution-data-server-1.2/camel-providers/libcamellocal.so
00878000-00879000 rwxp 00019000 08:12 40272190  
/usr/lib/evolution-data-server-1.2/camel-providers/libcamellocal.so
00879000-0087d000 r-xp 00000000 08:12 31326247   /lib/libnss_dns-2.6.so
0087d000-0087e000 r-xp 00003000 08:12 31326247   /lib/libnss_dns-2.6.so
0087e000-0087f000 rwxp 00004000 08:12 31326247   /lib/libnss_dns-2.6.so
0088b000-008dd000 r-xp 00000000 08:12 3276985    /usr/lib/libcamel-1.2.so.10.0.0
008dd000-008e0000 rwxp 00051000 08:12 3276985    /usr/lib/libcamel-1.2.so.10.0.0
008eb000-008ed000 r-xp 00000000 08:12 19070979   /usr/lib/evolution/2.10

--------------------------------------------------


Version-Release number of selected component (if applicable):
2.10.2-2.fc7 

How reproducible:
happens often at random times.
Comment 1 Milan Crha 2007-06-20 07:45:13 EDT
I could not reproduce this bug, somehow. I'm not sure if those
"e_categories_get_icon_file_for" warnings aren't from previous work with
calendar or contacts, there could be no need to look for categories icon when
moving mails between folders.

Could you try to install debug info for evolution and evolution-data-server, it
may produce better stack-trace. It could be also related on sorting in mail view
(each directory has its own sorting), maybe also how you move messages and so
on. I was trying with drag&drop with mouse, moving one email to other directory
and back, also moving more mails at one moment, last two, in the middle of the
list, and nothing wrong happened.

Please, try to find some exact steps, how to reproduce and if it will crash
again, send here stack trace with installed debug info packages. Thanks.
Comment 2 Stewart Hardie 2007-06-28 20:12:10 EDT
Created attachment 158179 [details]
back trace of evo crash

I have installed various debug packages for evolution 2.10.2-2.fc7 i386 and
dependencies. 

At the moment, crashing when shifting emails amongst IMAP folders happens
occassionally, but I have also noticed Evo crashing when sending a new email.
The problems may be related due to a copy of the sent email being copied to
'Sent Items' in IMAP folders.

The following back trace was generated by:
Open Evo. Open new message window. Address to myself, type in subject, some
content. Press 'Send'. Evo crashes.

I know that the email is actually sent, and a copy is put in 'Sent Items' on
IMAP folders before the crash, as they are there when I restart Evo.

Back trace is attached.
Comment 3 Stewart Hardie 2007-06-28 20:19:00 EDT
By the way, what I am calling Evo 'crashing' is the main Evo window freezing and
not responsive. I am forced to use 'Force quit' to close the window.

The sending email crash happens about 50% of the time.
Comment 4 Matthew Barnes 2007-06-29 08:18:39 EDT
evolution-2.10.2-3.fc7 (currently in Updates Testing) fixes a similar bug,
possibly the same as this.  Can you try upgrading and see if that helps?
Comment 5 Stewart Hardie 2007-08-01 01:27:04 EDT
evolution-2.10.2-3.fc7 and the current evolution-2.10.3-1.fc7 appear to have
fixed the crashing problem. I have not had evolution crash due to the above
problems since I upgraded to these versions.

Recommend that this bug be closed.
Comment 6 Milan Crha 2007-08-01 01:44:19 EDT
Feel free to close it (as a reporter you could).
Comment 7 Matthew Barnes 2007-08-01 12:23:01 EDT
Closing as CURRENTRELEASE.
Comment 8 Matthew Barnes 2007-08-01 12:28:26 EDT
For the record, I think this was bug #245289.

Note You need to log in before you can comment on or make changes to this bug.