Bug 244629 - When updating from RHEL 3.8 to 4.5 gstreamer-plugins update fails
Summary: When updating from RHEL 3.8 to 4.5 gstreamer-plugins update fails
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gstreamer-plugins   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-18 05:58 UTC by Wade Mealing
Modified: 2018-10-19 22:39 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0931
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:12:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0931 normal SHIPPED_LIVE gstreamer-plugins bug fix update 2007-11-14 19:38:26 UTC

Description Wade Mealing 2007-06-18 05:58:21 UTC
Description of problem:

gstreamer plugins update fails when upgrading (linux upgrade) from anaconda, it
looks as though the post-un section of the rpm runs gstreamer which, doesnt
exist during an upgrade.

Version-Release number of selected component (if applicable):

Upgrading from: gstreamer-plugins-0.6.0-18.i386.rpm 
Upgrading to:   gstreamer-plugins-0.8.5-1.EL.0.i386.rpm 

How reproducible:
Every time

Steps to Reproduce:
1. Install rhel3.8 (include desktop/gstreamer components)
2. upgrade (through anaaconda) to rhel4.5  (include desktop/gstramer components)
3. Watch gstreamer-plugins upgrade fail
  
Actual results:

error: %postun(gstreamer-plugins-0.6.0-18.ppc) scriptlet failed, exit status 127.


Expected results:

Upgrade to continue.

Additional info:

Seems to be a problem in the spec file, the rhel4u5 spec file changes ..

env DISPLAY= /usr/bin/gst-register-0.8 >/dev/null 2>&1

to

env DISPLAY= /usr/bin/gst-register-0.8 >/dev/null 2>&1 || true

Comment 9 Adam Jackson 2007-09-18 20:05:09 UTC
Fixing component.  Devel ack.

Comment 11 Adam Jackson 2007-09-20 19:44:52 UTC
Building as gstreamer-plugins 0.8.5-1.EL.1.  MODIFIED.

Comment 12 Adam Jackson 2007-09-21 14:56:24 UTC
Build failed:

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/gstreamer-plugins-0.8.5-root
error: Installed (but unpackaged) file(s) found:
   /usr/lib/gstreamer-0.8/libgstvideo4linux2.so

Full log at:
http://brewweb.devel.redhat.com/brew/getfile?taskID=977487&name=build.log

I assume we don't intend to change the plugin set for 4.6, so I'll fix the spec
file to nuke this plugin from the installroot before package creation.  Back out
to ASSIGNED...

Comment 13 Adam Jackson 2007-09-21 15:46:23 UTC
Built a new gstreamer-plugins 0.8.5-1.EL.1 successfully.  Back to MODIFIED.

Comment 18 errata-xmlrpc 2007-11-15 16:12:03 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0931.html



Note You need to log in before you can comment on or make changes to this bug.