Bug 24464 - mouse wheel support is broken in rxvt-2.7.5-8
mouse wheel support is broken in rxvt-2.7.5-8
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rxvt (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-20 14:48 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-20 14:48:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-20 14:48:50 EST
The configure test for mouse-wheel support in rxvt-2.7.5-8 seems to be reversed.  If $support_mousewheel is yes, then the configure script
defined NO_MOUSE_WHEEL -- which turns off mouse wheel support!

Here's a patch:

--- rxvt-2.7.5/autoconf/configure.in.mouse-wheel        Wed Sep 13 00:00:44 2000
+++ rxvt-2.7.5/autoconf/configure.in    Sat Jan 20 10:51:20 2001
@@ -1025,7 +1025,7 @@
 if test x$support_frills = xno; then
   AC_DEFINE(NO_FRILLS)
 fi
-if test x$support_mousewheel = xyes; then
+if test x$support_mousewheel != xyes; then
   AC_DEFINE(NO_MOUSE_WHEEL)
 fi
 if test x$support_oldselection = xno; then
Comment 1 Harald Hoyer 2001-01-22 09:09:02 EST
thanks

Note You need to log in before you can comment on or make changes to this bug.