Bug 24466 - ****Please Help**** Trying to install failure ANACONDA
****Please Help**** Trying to install failure ANACONDA
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-20 16:08 EST by batschelet
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 15:38:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script error txt (982 bytes, text/plain)
2001-01-20 16:09 EST, batschelet
no flags Details

  None (edit)
Description batschelet 2001-01-20 16:08:34 EST
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: dev

Local variables in innermost frame:
self: <comps.HeaderList instance at 8215888>
item: dev

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 1 batschelet 2001-01-20 16:09:47 EST
Created attachment 7888 [details]
script error txt
Comment 2 batschelet 2001-01-21 11:53:03 EST
More info:
Dell D
Hard Drive Instalation
Intel PII 450
Partitions
8Meg Fat32 OS:Win ME
5Meg Linix Native ........Root /
1M Linix Swap

After error occured I redownloaded all BASE and RPMS files
still didn't work
Could it be a corrupted boot.img?
Comment 3 batschelet 2001-01-21 12:28:06 EST
Downloaded Boot.img again and installed to A:\ with RAWRITE still have same 
problem.  

Note:  In the beggining of instalation process when it asks what language 
<ENGLISH>  There seems to be a problem there also. "OOPS" goes in place 
of "ENGLISH" and there is some code that shows on the screen "sorry couldn't 
copy".  But pressing enter gets you to the next menu.  It would seem that the 
info was corupted but I FTPed the entire BASE RPMS and Boot.img again?  From a 
different source yet the same error occurs??
Comment 4 batschelet 2001-01-21 12:31:06 EST
BASE and RPMS reside on the VFAT32 Win ME Partition could that be a problem

Note: I am new to lynix so I'm sure its something stupid I'm doing
Comment 5 John Agnew 2001-01-25 11:04:20 EST
I am having a very similary problem with installing anaconda. The text of the error message I received is pasted below.

I'm trying to install RH Linux 7.0 on a Dell Inspiron 8000 laptop computer with a PIII 850 processor, 256 MB RAM and 16MB video ram.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win2k

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 6 batschelet 2001-01-25 22:29:38 EST
I downloaded the anaconda fix from red hat and I got a NEW error so what could 
be the problem now? The problem file is indexhtml instead of dev.  

And yes I redownloaded  indexhtml 3 times in Binary mode. ****Please Help**** 
this is killing me I've tried like 30 times to install this program.  In just 
about every way that RedHat has said possible.  I've used you bug fix I've read 
all of your liturature and still just like about 2000 other people the problem 
still exists.  I'm not trying to bad mouth you guys but am trying to figure 
this out.

The new error is:


Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in 
readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: indexhtml

Local variables in innermost frame:
self: <comps.HeaderList instance at 820fec8>
item: indexhtml

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 7 batschelet 2001-01-26 08:50:01 EST
I got it to load!!!!! But now When I re boot I have a problem booting I get an 
error 10 X 0
Comment 8 Michael Fulbright 2001-01-26 11:39:08 EST
First, jagnew@giccs.georgetown.edu problem is fixed by an errata on the website.

Second, to the original bug reporter - when do you see the error message in your
last post?
Comment 9 batschelet 2001-01-26 14:09:31 EST
WHEN I BOOT MY COMPUTER I GET:
L  WITH A BLINKING CURSOR AND NO ACTIVITY

WHEN I USE THE START-UP DISK THAT I MADE FROM THE INSTALTION PROCESS LILO LOADS 
ON BOOT.  THEN AFTER A FEW SECONDS.

ERROR
10x0

ALSO WHAT SHOULD I DO DIFFERENTLY TO HAVE MY MBR GIVE ME AN OPTION OF WHAT OPP 
SYS TO USE.  I HAD THAT OPTION BEFORE I INSTALLED AND NOW I DON'T.  ANY HELP 
WOULD BE APPRECIATED, AND THANKS FOR THE REPLY.

Comment 10 Geoffrey Hutchinson 2001-02-02 14:43:59 EST
During install of RH 6.2 from a floppy (using the updated
boot20000407.img and update-disk-20000407.img) and a CD I burned using the zoot-
i386.iso I get all the way to the package install routine and then die.
 
The error is very similar to some earlier ones posted in these groups: ---
File "/usr/lib/anaconda/comps.py",
  line 46, in __getitem__
  return self.packages[item]
  Keyerror: basesystem
---
only most of the others have keyerror: indexhtml.  Anyway, I've updated the 
boot diskette so that's not it.  I also read that the hdlist may not match my 
RPMs but that can't be it b/c I d/l'd the iso file right from ftp.redhat.com.
 
Also, it can't be an architecture issue (I think) b/c I've had RH 6.0 and X 
running on this machine (Dell 8100 1.3Ghz Ultra ATA 40Gb drive and Nvidia TNT2).
 
It shouldn't be a CD burning issue (iso standard vs. Rock Ridge vs. Joliet) b/c 
if it were I would never get that far anyway.
Comment 11 John Recine, Jr. 2001-02-06 15:04:04 EST
Ok i got the same problem, and i have downloaded the anaconda patch.  I have a 
P3 550, 2 hard drives, 1 10gigs, the other 20gigs, 128 of ram, and i am doing 
the hard drive install. ive tried this like 10 times and i still get the same 
error.
Comment 12 Michael Fulbright 2001-02-06 15:38:14 EST
There problems are all related to not having created the proper hard drive image
to install from.
Comment 13 Need Real Name 2001-02-10 04:45:08 EST
Keyerror: indexhtml is due to many Windows FTP programs have auto-type detect, 
and infer (wrongly) that the indexhtml RPM file should be transferred as 
ASCII.  This will corrupt the RPM.

Note You need to log in before you can comment on or make changes to this bug.