Bug 244692 - laptop special keys do not work
Summary: laptop special keys do not work
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Zdenek Prikryl
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-18 15:42 UTC by Richard Kennedy
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 09:25:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Events created by xev (10.05 KB, application/octet-stream)
2007-06-28 02:18 UTC, Stian Moltubakk
no flags Details

Description Richard Kennedy 2007-06-18 15:42:58 UTC
Description of problem:
No acpi events are generated when pressing laptop special keys.

JVC minnote laptop has special blue keys that create acpi events, such as
event=hotkey HOTK 00000032 

These no longer work on fedora 7.

Version-Release number of selected component (if applicable):


How reproducible:
always
 


Steps to Reproduce:
1. press key
2. view /var/log/acpi
3.
  
Actual results:
none

Expected results:
/etc/acpi/action script runs

Additional info:
These keys worked on FC6 & I think that these keys where handled by the
asus_acpi module, but this is not shipped with the kernels in F7.

Comment 1 Stian Moltubakk 2007-06-28 02:18:17 UTC
Created attachment 158089 [details]
Events created by xev

Events created by xev

Comment 2 Stian Moltubakk 2007-06-28 02:19:18 UTC
I typed acpi_listen in fc6 on my ASUS and get this.

toutchpad: hotkey ATKD 0000006b 00000001
Browser: hotkey ATKD 00000051 00000002
E-mail: hotkey ATKD 00000050 00000002
Powermode: hotkey ATKD 0000005c 00000002
CD player start: hotkey ATKD 0000004c 00000000

Play: none
Fn: none
Prev:none
Next:none
Stop:none

Now I do the same on the same ASUS in F7 and get nothing.

But I do get a output using xev on Play,Prev,Next and stop, but no others.(see 
atatchment)

I recal having asus acpi and other computer brands folders in /proc/acpi , but 
I can no longer find them.

I find something about ACPI in /boot/config-KERNEL.fc7 looking like this.
# ACPI (Advanced Configuration and Power Interface) Support
#
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
# CONFIG_ACPI_SLEEP_PROC_SLEEP is not set
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=y
CONFIG_ACPI_DOCK=m
CONFIG_ACPI_BAY=m
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_HOTPLUG_CPU=y
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_NUMA=y
# CONFIG_ACPI_ASUS is not set
CONFIG_ACPI_IBM=m
CONFIG_ACPI_IBM_BAY=y
CONFIG_ACPI_TOSHIBA=m
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
CONFIG_ACPI_CONTAINER=y
CONFIG_ACPI_SBS=m



Comment 3 Richard Kennedy 2007-06-28 13:43:50 UTC
thanks for the info.
Unfortunately xev does not show any events for these keys.
& acpi_listen does not see them either.

maybe we do need the asus_acpi module after all ?
Should this be marked as a kernel bug ?
 

Comment 4 Stian Moltubakk 2007-07-02 04:48:36 UTC
/etc/rc.d/rc.local and add the "modprobe asus-laptop" fixed the problem for me, 
now I get a output from acpi_listen. I gues you could try "modprobe jvc-laptop" 
instead. Fedora seams to have replaced the old acpi with there own invention 
witch I think is a shame since I gues this means I can no longer make my FN key 
work using fnfx and Thosiba acpi. I was hoping I could do that with some 
trixingand fixning.



Comment 5 Richard Kennedy 2007-07-02 14:08:44 UTC
modprobe asus-laptop fixed for me. thanks for help



Note You need to log in before you can comment on or make changes to this bug.