Bug 244693 - Network device selection fails during new VM creation process
Summary: Network device selection fails during new VM creation process
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
(Show other bugs)
Version: 7
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-18 15:45 UTC by Adam Huffman
Modified: 2008-03-12 20:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 20:10:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of network device page (38.72 KB, image/png)
2007-06-18 15:45 UTC, Adam Huffman
no flags Details

Description Adam Huffman 2007-06-18 15:45:16 UTC
Description of problem:

I've been trying to use virt-manager to create a new HVM under F7.  The
application proceeds quite happily until the "Connect to host network" page. 
I'm trying to select the physical device option, but the drop down appears as a
very thin line.

Version-Release number of selected component (if applicable):
virt-manager-0.4.0-2.fc7
libvirt-0.2.3-1.fc7


How reproducible:
Every time

Steps to Reproduce:
1. Start new guest creation
2.
3.
  
Actual results:
New guest creation fails at host network creation page

Expected results:
Should be able to select a network device.

Additional info:

Comment 1 Adam Huffman 2007-06-18 15:45:16 UTC
Created attachment 157290 [details]
Image of network device page

Comment 2 Daniel Berrange 2007-06-18 15:55:18 UTC
If the 'Shared physical device' list doesn't have any devices listed, then none
of your ethernet devices are members of a bridge.

If you are using Xen, then the network-bridge script will make eth0 part of a
bridge. The recommended way is to use the regular network scripts though.

In /etc/sysconfig/network-scripts: the file ifcfg-peth0 should define the
physical device, with something like

DEVICE=peth0
ONBOOT=yes
BRIDGE=eth0
HWADDR=XX:XX:XX:XX:XX:XX

and the file ifcfg-eth0 should be defining the bridge device to which the
physical device is enslaved:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Bridge


If you have already got eth0 enslaved in a bridge & virt-manager dosn't work,
please provide ifconfig -a and  brctl show   output.


Comment 3 Adam Huffman 2007-06-18 16:01:46 UTC
Should this 'ifcfg-peth0' file have been created automatically?  I do have a
virbr0 device, but nothing appears to be using it:

eth0      Link encap:Ethernet  HWaddr 00:18:8B:1D:9A:CB  
          inet addr:xx.xx.xx.xx  Bcast:xx.xx.xx.255  Mask:255.255.255.0
          inet6 addr: fe80::218:8bff:fe1d:9acb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1665844 errors:0 dropped:0 overruns:0 frame:0
          TX packets:452804 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:471571008 (449.7 MiB)  TX bytes:55414602 (52.8 MiB)
          Interrupt:16 


virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:10336 (10.0 KiB)


Comment 4 Daniel Berrange 2007-06-18 16:04:30 UTC
No, the default scripts in /etc/sysconfig/network-scripts  do not setup eth0 in
a bridged configuration. This is because bridging doesn't work for many
scenarios (Wifi, networkmanager, any machines with dynamic networking in
general), so the safe option is not to setup any bridged ethernet devs.  The
virbr0  is a simple  NAT based transit for guest VMs  whcih is safe to configure
for out-of-box connectivity (virbr0 corresponds to "Virtual Networks" 'default'
network in virt manager).


Comment 5 Adam Huffman 2007-06-18 16:14:38 UTC
That sounds fair enough, but shouldn't this be documented e.g. at
http://fedoraproject.org/wiki/Docs/Fedora7VirtQuickStart?  Or have I missed it?

Incidentally, I've just tried using the 'default' network and that has crashed,
but I think the problem is covered by other reports.

Comment 6 Red Hat Bugzilla 2007-07-25 02:14:10 UTC
change QA contact

Comment 7 Cole Robinson 2008-03-12 20:10:43 UTC
Hi, I'm closing this as NOTABUG since there doesn't seem to be an issue here.


Note You need to log in before you can comment on or make changes to this bug.