This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 244759 - Config Management File pages have too generic of a help link
Config Management File pages have too generic of a help link
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Máirín Duffy
Preethi Thomas
:
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2007-06-18 20:52 EDT by Mike McCune
Modified: 2008-04-02 20:24 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
list of pages => context links (3.99 KB, text/plain)
2008-02-08 14:17 EST, Máirín Duffy
no flags Details

  None (edit)
Description Mike McCune 2007-06-18 20:52:54 EDT
Go to:

1) configuration
2) go to a config channel
3) view a file so you are looking at:

/rhn/configuration/file/FileDetails.do?cfid=XXX

4) note the help link goes to:

/help/reference/s1-sm-channels-packages.html#S2-SM-CONFIG-MANAGE

but we have specific sections in the docs for this:

<a name="S3-SM-FILE-DETAILS">6.6.6.6. Configuration File Details — 

in the above mentioned html page.
Comment 1 Mike McCune 2007-06-18 20:54:17 EDT
Will need to better parameterize the help links in the jspf:

<%@ include file="/WEB-INF/pages/common/fragments/configuration/files/header.jspf"%>

to pass in a help-link param or something along those lines.
Comment 2 Máirín Duffy 2007-11-01 19:42:25 EDT
Sending        common/fragments/configuration/files/header.jspf
Transmitting file data .
Committed revision 133445.

TESTPLAN
========
1) configuration
2) go to a config channel
3) view a file so you are looking at:

/rhn/configuration/file/FileDetails.do?cfid=XXX

4) note the help link should go to:
/help/reference/s1-sm-channels-packages.html#S3-SM-FILE-DETAILS
Comment 3 Preethi Thomas 2007-11-27 16:48:02 EST
fails qa

it should be going to 
6.6.6.6. Configuration File Details —
https://rlx-0-10.rhndev.redhat.com/rhn/help/reference/en/s3-sm-file-details.jsp

but right now it goes to
6.6. Channels
https://rlx-0-10.rhndev.redhat.com/rhn/help/reference/en/s1-sm-channels-packages.jsp#S3-SM-FILE-DETAILS
Comment 4 Máirín Duffy 2007-11-28 08:37:21 EST
Preethi, it looks like ALL of the context sensitive links are now broken. There
much have been a change in the way the docs are built or something that breaks
all of our links.

I filed bug 402711. I don't think this context link should be changed to this
new format and every single other one broken; I think if possible it would be
better to change the generated html of the docs to once again comply to the
format the web context sensitive links expect.

I am changing this bug to NEEDINFO and making it dependent on bug 402711.
Comment 5 Máirín Duffy 2008-02-08 14:17:16 EST
Created attachment 294400 [details]
list of pages => context links

attaching list of pages, their suggested context links, separated by which
pages have good links and which have missing links or links that will change
when bug 402711 is fixed.
Comment 6 Máirín Duffy 2008-02-11 11:40:24 EST
updating context-links based on current state of rhn 5.1 docs. 

TESTPLAN
=========

Please see attachment 294400 [details] in comment 5 for a list of the pages that should
have updated context help links. They should now be pointing the docs pages
referenced per page (or block of pages) in that file.
Comment 8 Pradeep Kilambi 2008-03-19 23:08:00 EDT
release pending
Comment 9 Brandon Perkins 2008-04-02 20:24:24 EDT
5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.