Bug 244782 - BUG: sleeping function called from invalid context at kernel/rwsem.c:20
BUG: sleeping function called from invalid context at kernel/rwsem.c:20
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 02:01 EDT by Peter Bieringer
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 22:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2007-06-19 02:01:33 EDT
I got following this bug on every resume-from-disk on a
laptop.

I found similar message in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201508 but it was told me
to open a new bug.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3228.fc7

grub.conf:
      kernel /boot/vmlinuz-2.6.21-1.3228.fc7 ro root=LABEL=/ vga=0x317
pci=usepirqmask,noacpi noapic irqpoll 5

(PCI and APIC options are required for non-suddenly-jumping-external-mouse support)

dmesg:

agpgart-via 0000:00:00.0: EARLY resume
BUG: sleeping function called from invalid context at kernel/rwsem.c:20
in_atomic():0, irqs_disabled():1
 [<c0439f26>] down_read+0x12/0x28
 [<c04f05ad>] pci_get_subsys+0x71/0xf3
 [<c052259c>] acpi_pci_link_get_current+0x69/0xc9
 [<c051f6e6>] acpi_bus_get_status+0x32/0x8a
 [<c04f0645>] pci_get_device+0x16/0x19
 [<c04eed1b>] quirk_vialatency+0x18/0xcd
 [<c04ee602>] pci_fixup_device+0x6d/0x78
 [<c04efd3d>] pci_device_resume_early+0x14/0x2a
 [<c055665f>] dpm_power_up+0x93/0xc4
 [<c044595b>] swsusp_suspend+0x4d/0x54
 [<c0445ffe>] pm_suspend_disk+0x101/0x21f
 [<c0444e2e>] enter_state+0x4d/0x1c8
 [<c044502e>] state_store+0x85/0x99
 [<c0444fa9>] state_store+0x0/0x99
 [<c04ab9e6>] subsys_attr_store+0x1e/0x22
 [<c04abb0a>] sysfs_write_file+0xbd/0xe7
 [<c04aba4d>] sysfs_write_file+0x0/0xe7
 [<c0475c97>] vfs_write+0xa8/0x154
 [<c04762a6>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
Applying VIA southbridge workaround.

Additional info:
$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : mobile AMD Athlon(tm) XP-M 1800+
stepping        : 0
cpu MHz         : 800.056
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
mmx fxsr sse syscall mp mmxext 3dnowext 3dnow up ts fid vid
bogomips        : 1600.82
clflush size    : 32


Additional info:
It looks like this bug do not cause big problems, because system can be used
after resume.
Comment 1 Nigel Cunningham 2007-07-02 22:07:54 EDT
Yeah, despite the "BUG", it's just a warning. The ACPI code is calling a
function that might sleep from a context in which it's not supposed to sleep. I
would recommend taking the issue to the ACPI guys. You can contact them via the
http://acpi.info website.
Comment 2 Peter Bieringer 2007-07-04 16:18:45 EDT
Looks like acpi.info do not want any e-mail anymore:

$ host -t mx acpi.info  ns1.acpi.info. 
Using domain server:
Name: ns1.acpi.info.
Address: 63.64.153.68#53
Aliases: 

acpi.info mail is handled by 10 .

$ host -t mx acpi.info  tfserver.theriens.com.
Using domain server:
Name: tfserver.theriens.com.
Address: 67.189.64.166#53
Aliases: 

acpi.info has no MX record


Anyway, do I understand it right that it is a problem in the ACPI code stored in
BIOS and not in the kernel source code?

Note You need to log in before you can comment on or make changes to this bug.