Bug 244785 - yum ignores the --disablerepo option
yum ignores the --disablerepo option
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 02:48 EDT by Matteo Corti
Modified: 2014-01-21 17:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 08:45:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matteo Corti 2007-06-19 02:48:38 EDT
Description of problem:
yum ignores the --disablerepo option

Version-Release number of selected component (if applicable):
yum-3.2.0-1.fc7

How reproducible:
always

Steps to Reproduce:
1. yum --disablerepo=REPONAME
  
Actual results:
repository is not excluded

Expected results:
repository should be ignored

Additional info:

Example:
# yum --disablerepo=skype upgrade
Loading "priorities" plugin
Loading "presto" plugin
Loading "dellsysidplugin" plugin
Loading "installonlyn" plugin
Loading "downloadonly" plugin
Loading "skip-broken" plugin
Loading "fastestmirror" plugin
Loading "fedorakmod" plugin
Loading "protectbase" plugin
Setting up Presto


Cannot open/read repodata/repomd.xml file for repository: skype

In this case the unreachable repository (skype) should be ignored since it was
disabled from the command line

setting enable=0 in the configuration file is also not working

Running with -d 9 does not give more information:

# yum -d 9 --disablerepo=skype upgrade
Loading "priorities" plugin
Loading "presto" plugin
Loading "dellsysidplugin" plugin
Loading "installonlyn" plugin
Loading "downloadonly" plugin
Loading "skip-broken" plugin
Loading "fastestmirror" plugin
Loading "fedorakmod" plugin
Loading "protectbase" plugin
Running "config" handler for "priorities" plugin
Running "config" handler for "presto" plugin
Running "config" handler for "installonlyn" plugin
Running "config" handler for "downloadonly" plugin
Running "config" handler for "skip-broken" plugin
Running "config" handler for "protectbase" plugin
Running "postconfig" handler for "dellsysidplugin" plugin
Running "init" handler for "dellsysidplugin" plugin
Running "init" handler for "fastestmirror" plugin
Running "init" handler for "fedorakmod" plugin
Loading Fedora Extras kernel module support.
Running "postreposetup" handler for "presto" plugin
Setting up Presto


Cannot open/read repodata/repomd.xml file for repository: skype
Comment 1 Jeremy Katz 2007-06-19 08:29:12 EDT
I believe this is due to some fun with the presto plugin -- can you try
disabling it and see if that improves things?  If so, then this will be resolved
in yum 3.2.1
Comment 2 Matteo Corti 2007-06-19 08:36:48 EDT
I removed the presto plugin and everything works as expected. I should have
noticed that the problem was accurring too early and that the probable cause was
a plugin.

Thanks
Comment 3 Jeremy Katz 2007-06-19 08:45:56 EDT
Well, to be fair, what presto is doing _should_ work.  It's just a yum bug
that's keeping that from being the case.  But good to know; will be fixed when
we push the yum 3.2.1 update later this week

Note You need to log in before you can comment on or make changes to this bug.