Bug 244791 - null error message when attemping vgsplit of snap origin
null error message when attemping vgsplit of snap origin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 04:21 EDT by Milan Broz
Modified: 2013-02-28 23:05 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0516
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:48:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2007-06-19 04:21:58 EDT
+++ This bug was initially created as a clone of Bug #238487 +++
RHEL5 clone

Description of problem:

[root@basic ~]# pvs
  PV         VG            Fmt  Attr PSize  PFree
  /dev/sda3  VolGroup00    lvm2 a-   68.25G  64.00M
  /dev/sdc1  stripe_2_2252 lvm2 a-    1.59T 240.00M
  /dev/sdd1  stripe_2_2252 lvm2 a-    1.59T 240.00M
  /dev/sde1  stripe_2_2252 lvm2 a-    1.59T   1.59T
  /dev/sdf1  stripe_2_2252 lvm2 a-    1.59T   1.59T
  /dev/sdg1  stripe_2_2252 lvm2 a-    1.59T   1.59T
  /dev/sdh1  stripe_2_2252 lvm2 a-    1.59T   1.59T
[root@basic ~]# vgs
  VG            #PV #LV #SN Attr   VSize  VFree
  VolGroup00      1   2   0 wz--n- 68.25G 64.00M
  stripe_2_2252   6   1   3 wz--n-  9.55T  6.37T


[root@basic ~]# lvs -a -o +devices
  LV             VG            Attr   LSize   Origin         Snap%  Move Log
Copy%  Devices           
  LogVol00       VolGroup00    -wi-ao  66.25G                                  
    /dev/sda3(0)      
  LogVol01       VolGroup00    -wi-ao   1.94G                                  
    /dev/sda3(2120)   
  snap0          stripe_2_2252 swi--- 100.00M stripe_2_22520                   
    /dev/sde1(0)      
  snap1          stripe_2_2252 swi--- 100.00M stripe_2_22520                   
    /dev/sdf1(0)      
  snap2          stripe_2_2252 swi---  76.00M stripe_2_22520                   
    /dev/sdg1(0)      
  stripe_2_22520 stripe_2_2252 owi---   3.18T                                  
    /dev/sdc1(0),/dev/sdd1(0)


[root@basic ~]# vgsplit stripe_2_2252 split_885 /dev/sdc1 /dev/sdd1
  /dev/cdrom: open failed: Read-only file system
  Attempt to close device '/dev/cdrom' which is not open.
  Snapshot (null) split


Since sdd and sdc are both being used in the vg, I think that lvm is correct in
having the cmd fail, but it should give a valid error message, I believe like
the following:

[root@basic ~]# vgsplit stripe_2_2252 split_885 /dev/sdc1 /dev/sde1
  /dev/cdrom: open failed: Read-only file system
  Attempt to close device '/dev/cdrom' which is not open.
  Can't split Logical Volume stripe_2_22520 between two Volume Groups


Version-Release number of selected component (if applicable):
[root@basic ~]# rpm -q lvm2
lvm2-2.02.21-5.el4
[root@basic ~]# uname -ar
Linux basic 2.6.9-55.ELlargesmp #1 SMP Fri Apr 20 17:07:53 EDT 2007 ppc64 ppc64
ppc64 GNU/Linux


How reproducible:
everytime

-- Additional comment from mbroz@redhat.com on 2007-05-15 11:00 EST --
Fixed upstream in 2.02.26.
Comment 1 RHEL Product and Program Management 2007-06-19 04:24:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Corey Marthaler 2007-06-27 18:08:01 EDT
fix verified in lvm2-2.02.26-1.el5
Comment 5 errata-xmlrpc 2007-11-07 11:48:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0516.html

Note You need to log in before you can comment on or make changes to this bug.