Bug 244834 - RHEL5.1 : mkinitrd multipath changes breaks iSCSI root
RHEL5.1 : mkinitrd multipath changes breaks iSCSI root
Status: CLOSED DUPLICATE of bug 185852
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 09:07 EDT by Mark McLoughlin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 10:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2007-06-19 09:07:22 EDT
This change:

  * Mon Jun 18 2007 David Cantrell <dcantrell@redhat.com> - 5.1.19.6-4
  - Make sure to copy in /var/lib/multipath/bindings to the initrd
  - Bring up multipath devices by WWID on initrd boot
  - Resolves: rhbz#185852
  - Resolves: rhbz#216240

seems to have broken iSCSI root

The problem is simple - we now attempt to start the iSCSI initiator before
bringing up the network device

A custom initrd with the network line re-ordered before the iscsistart line
works fine for me
Comment 1 RHEL Product and Program Management 2007-06-19 10:44:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 David Cantrell 2007-06-19 10:46:59 EDT
Marking as a dupe of bug #185852 since this is related and part of the larger
rhel5-multipath feature.  Not exactly a dupe, but still marking it because this
change needs to be in that patch.

*** This bug has been marked as a duplicate of 185852 ***

Note You need to log in before you can comment on or make changes to this bug.