Bug 244887 - system-config-httpd maybe adds two Listen directives
system-config-httpd maybe adds two Listen directives
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: redhat-config-httpd (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 13:49 EDT by John D. Ramsdell
Modified: 2015-03-04 20:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John D. Ramsdell 2007-06-19 13:49:53 EDT
Description of problem:

On F7, when I tried to start httpd, I got:

root@goo daemon-example]# service httpd start
Starting httpd: (98)Address already in use: make_sock: could not bind to address
[::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                     [FAILED]

I failed to find any application that was using port 80.  Eventually, I ran a
program I wrote, and demonstrated that it could use port 80.

[root@goo daemon-example]# ./broadcast 80
Broadcast 2808 listening on 80
accepting file descriptor 4
closing file descriptor 4

I eventually gave up fighting the bug, and reinstalled.  The problem
disappeared.  I followed my usual procedure for the reinstallation, which
includes selecting the office automation, development tools, and web server option.

The first installation was done with kickstart, and it gave me a different menu
for installing optional software, such as the web server.  The first
installation included the program system-config-httpd, which I used to set the
host name of the web server.  The second installation did not include that program.

After I did the reinstall, I've been told the problem I had could be explained
if the httpd configuration file had two Listen directives.  Unfortunately, I do
not have the old configuration file to verify this diagnosis.
Comment 1 John D. Ramsdell 2007-06-22 14:02:10 EDT
I spoke to someone within my company with the same problem.  In his case, after
using the GUI configuration manager, he ended up with a Listen directive in
/etc/httpd/conf/httpd.conf, and another one in
/etc/httpd/conf.d/system-config-httpd.conf.  Removing on of the directives fixed
his problem.  He was using FC6, so maybe his comment does not apply to F7.
Comment 2 John D. Ramsdell 2007-06-26 11:27:15 EDT
Someone on the Fedora Forum reports he too found a Listen directive in both
/etc/httpd/conf/httpd.conf, and /etc/httpd/conf.d/system-config-httpd.conf.

The Forum thread is:

http://forums.fedoraforum.org/showthread.php?t=157870&goto=newpost
Comment 3 Bug Zapper 2008-05-14 09:12:05 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2008-06-16 21:39:12 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.