Bug 244900 - power button no longer does anything unless logged in on console
power button no longer does anything unless logged in on console
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: acpi (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 14:56 EDT by Wolfgang Rupprecht
Modified: 2008-03-20 13:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 13:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rupprecht 2007-06-19 14:56:44 EDT
Description of problem:

The computer's power button no longer does anything unless one is logged in on
the console.  This is a big problem for headless machines.  If one could log in
on the console one doesn't really need the power button to shutdown.

Shutting down headless machines via the power button used to work fine under 
fc6.

Version-Release number of selected component (if applicable):
everything yum updated to current levels as of this bug report.
  
How reproducible:
100%

Steps to Reproduce:
1. log out and wait for the gdm login prompt to appear.
2. press the power button. 
3. wait, notice nothing is happening. 
  
Actual results:
nothing happens

Expected results:
the computer should do a clean shutdown.

Additional info:
This happens on all 3 of my f7 systems (1x 686, 2x x86_64).
Comment 1 Kamil J. Dudek 2007-07-06 15:42:56 EDT
On my machine - power button does completely nothing. INIT 3,5, gdm, session, 
whenever. FC6 did a clean poweroff.
Comment 2 James Ralston 2007-07-06 18:30:56 EDT
I've found that the power button works if I'm logged into an X session (e.g.,
because I logged into the console and ran "startx").

Having the power button do nothing unless you're logged into the machine is
really obnoxious.  I suspect some badness/misfeaturism occurred in ConsoleKit.

Wolfgang, please consider changing the priority of this bug from "low" to "medium".
Comment 3 Wolfgang Rupprecht 2007-07-06 18:45:42 EDT
(In reply to comment #2)
> Wolfgang, please consider changing the priority of this bug from "low" to 
> "medium"

I'm quite willing to change the priority if it is the correct rating for a bug
of this sort.  My reading of the following url leads me to believe it is
severity "low" for folks that are able to click on "shutdown" on the gdm console
 and severity "high" for headless servers.  Maybe "medium" is the correct
average severity. ;-)  Please, some Redhat or Fedora person help rate the
severity of this bug correctly.

https://bugzilla.redhat.com/bugzilla/page.cgi?id=fields.html#bug_severity

Comment 4 James Ralston 2007-07-06 20:12:01 EDT
My $0.02: leaving the severity at "medium" is generally the best strategy,
unless you're absolutely sure a different priority is warranted.  (Bug assignees
can always adjust the priority as they see fit.)
Comment 5 Till Maas 2007-08-15 11:01:05 EDT
(In reply to comment #0)

> Steps to Reproduce:
> 1. log out and wait for the gdm login prompt to appear.
> 2. press the power button. 
> 3. wait, notice nothing is happening. 
>   
> Actual results:
> nothing happens

Is there any output in the acpid logfile, when you press the button?:
tail -f /var/log/acpid

Is the module button.ko loaded?
$ lsmod  | grep button
button                 12113  0

What is the output of the following?
/bin/ps awwux | /bin/grep gnome-power-manager | /bin/grep -qv grep || echo true
Comment 6 James Ralston 2008-03-04 23:20:46 EST
I haven't experienced any problems with the power button not behaving as
expected since I upgraded to Fedora 8.

Can anyone reproduce this problem against Fedora 8?
Comment 7 James Ralston 2008-03-20 13:33:32 EDT
As per comment 6, I'm quite certain that F8 resolves this.  I suggest closing
with CURRENTRELEASE.
Comment 8 James Ralston 2008-03-20 13:35:47 EDT
Oops... I didn't mean to close this, but since I did, I'll change the resolution
appropriately...

Note You need to log in before you can comment on or make changes to this bug.