Bug 244916 - update to xinetd causes amanda client to timeout/ fail
update to xinetd causes amanda client to timeout/ fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amanda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Radek Brich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 16:14 EDT by Michael Belanger
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.5.1p3-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 13:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Belanger 2007-06-19 16:14:56 EDT
Description of problem:

Yum update to xinetd.i386 2:2.3.14-12.fc7 caused amanda backups to fail on that
host. 

<error>
WARNING: white: selfcheck request failed: timeout waiting for ACK
Client check: 22 hosts checked in 29.997 seconds, 1 problem found
</error>

I reverted back to xinetd-2.3.14-11.i386.rpm and amanda was working again for
that host. 

How reproducible:


Steps to Reproduce:
1. update to xinetd.i386 2:2.3.14-12.fc7
2. restart xinetd
3. on backup server: amcheck -c <backupconfig> <hostname>
  
Actual results:

Amanda Backup Client Hosts Check
--------------------------------
WARNING: <hostname>: selfcheck request failed: timeout waiting for ACK
Client check: 22 hosts checked in 29.997 seconds, 1 problem found

Expected results:

Amanda Backup Client Hosts Check
--------------------------------
Client check: 22 hosts checked in 0.090 seconds, 0 problems found


Additional info:
Comment 1 Charles Curley 2007-06-22 17:55:56 EDT
I can confirm both the symptom and the workaround. Thank you, Mr. Belanger.
Comment 2 Radek Brich 2007-06-26 07:43:40 EDT
You can also try add "flags = IPv4" to /etc/xinetd.d/amanda. Then it should work
with new xinetd too.

The cause of that timeout is xinetd's patch for bug #195265. Before, IPv4 socket
was bind by default, now it's IPv6 with fallback to IPv4 on error. It seems that
amanda is not retrying connection on error.

With new amanda it works fine, so I'll try backporting patch for this...
Comment 3 Charles Curley 2007-06-26 13:39:02 EDT
Adding "flags = IPv4" appears to work for me. Thanks.

[root@charlesc samba]# pre xinetd amanda | sort
amanda-2.5.1p3-1.fc7
amanda-client-2.5.1p3-1.fc7
amanda-server-2.5.1p3-1.fc7
xinetd-2.3.14-12.fc7
Comment 4 Michael Belanger 2007-06-28 17:25:46 EDT
That setting in /etc/xinetd.d/amanda seems to work for me as well.  

Comment 5 Peter Bieringer 2007-07-01 09:09:35 EDT
Happen to me, too and can confirm working. Not nice that amanda has still
problems with IPv6...
Comment 6 Gwyn Ciesla 2007-07-02 13:23:41 EDT
Works for me, too.
Comment 7 Fedora Update System 2007-07-09 11:48:19 EDT
amanda-2.5.1p3-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Radek Brich 2007-07-12 09:35:35 EDT
So what I did? Just added that line (flags=IPv4) to default xinetd config file.
It will not auto-repair amanda when upgrading but it should at least help when
configuring it.

I didn't found better solution.
Comment 9 Fedora Update System 2007-07-16 13:00:53 EDT
amanda-2.5.1p3-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.