Bug 244958 - spamassassin wants access to shadow
Summary: spamassassin wants access to shadow
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spamassassin   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 04:33 UTC by Joe Brown
Modified: 2008-08-04 18:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 18:59:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Brown 2007-06-20 04:33:40 UTC
Description of problem:
selinux enforcing / spamassassin
Does spamassassin need /shadow access?

Bug 

Version-Release number of selected component (if applicable):
spamassassin-3.1.9-1.el5

How reproducible:


Steps to Reproduce:
1. install spamassassin
2. turn it on for all
3. view /var/log/messages
  
Actual results:
avc: denied { read } for comm="spamassassin" dev=dm-0 egid=12 euid=0
exe="/usr/bin/perl" exit=-13 fsgid=12 fsuid=0 gid=12 items=0 name="shadow"
pid=27858 scontext=system_u:system_r:procmail_t:s0 sgid=12
subj=system_u:system_r:procmail_t:s0 suid=0 tclass=file
tcontext=system_u:object_r:shadow_t:s0 tty=(none) uid=0 


Expected results:
none

Additional info:

Spamassassin also had issues w/tmp,
restorecon -R -v /tmp #presumably resolved that issue.

avc: denied { search } for comm="spamassassin" dev=dm-0 egid=12 euid=0
exe="/usr/bin/perl" exit=-13 fsgid=12 fsuid=0 gid=12 items=0 name="tmp"
pid=27858 scontext=system_u:system_r:procmail_t:s0 sgid=12
subj=system_u:system_r:procmail_t:s0 suid=0 tclass=dir
tcontext=system_u:object_r:tmp_t:s0 tty=(none) uid=0

Comment 1 Warren Togami 2007-06-20 08:27:31 UTC
How are you using spamassassin?  (As spamc/spamd?  spamassassin called by
procmail?  More details please.)

Were you previously using spamassassin-3.1.8 without issue on this same OS and
server?

Comment 2 Warren Togami 2007-06-20 08:36:13 UTC
http://mail-archives.apache.org/mod_mbox/spamassassin-users/200602.mbox/%3c20060227185106.GK12823@kluge.net%3e
There was a thread about spamassassin sometimes trying to read /etc/shadow
during February 2006.  Apparently this is normal?

I haven't heard complaints like this before.  So perhaps your filesystem has
been improperly labeled or unlabeled?


Comment 3 Warren Togami 2008-08-04 18:59:05 UTC
Closing as NOTABUG because of lack of response in more than a year, and nobody else reporting this as an issue.


Note You need to log in before you can comment on or make changes to this bug.