Bug 244971 - Update OpenSceneGraph to 2.0
Update OpenSceneGraph to 2.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: OpenSceneGraph (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
: 246065 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 05:13 EDT by Christian Nolte
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0-9.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 23:35:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2007-06-20 05:13:39 EDT
I have not found any plans for updating OSG to 2.0 in fedora, so I am asking it
here: please update OpenSceneGraph to the current stable version 2.0.
Comment 1 Ralf Corsepius 2007-06-20 06:34:03 EDT
I am currently looking into OSG-2.0, but so far all I can tell is:
There probably won't be an upgrade to OSG-2.0 for Fedora 7.

If OSG-2.0 will be introduced, then on rawhide first, but too much has changed
with OSG to be able to tell if and when this will happen.



Comment 2 Christian Nolte 2007-06-20 15:35:12 EDT
Ok thank you for the information. If you don't mind you could use this bug to
track progess on this.
Comment 3 Ralf Corsepius 2007-06-28 06:18:06 EDT
*** Bug 246065 has been marked as a duplicate of this bug. ***
Comment 4 Rudolf Kastl 2007-06-28 06:52:28 EDT
#1 what are the actual problems you see? what is left to be solved for building
osg 2.0 on rawhide? (wfm)
Comment 5 Ralf Corsepius 2007-06-28 07:51:10 EDT
1. Upstream has switched to cmake and had screwed it.
I meanwhile believe to have sorted out the issues, but ... I can not avoid to
having to reiterate my mantra: cmake sucks.


2. NEVR problems related to dist-upgrading:
We have been shipping OpenThreads, Producer and OpenSceneGraph as separate
packages. With OSG-2.0, upstream has dropped Producer and merged-in OpenThreads.

This raises problems with yum (apt can handle this case):
# yum update
...
--> Processing Dependency: libOpenThreads.so.1 for package: Producer
--> Finished Dependency Resolution
Error: Missing Dependency: libOpenThreads.so.1 is needed by package Producer

To work around these issues I am considering to either ship compat-OSG-1
packages or to introduce OSG-2 as OpenSceneGraph-2 and to keep OSG-1.
Comment 6 Rudolf Kastl 2007-06-28 08:31:25 EDT
1. dont see any cmake problems and its better than the solution they had before.
(my personal opinion since i dont have anything against cmake compared to lets
some selfhacked shellscript that builds things)

2. cant you just build producer vs osg2? tried it? if it doesent work is it 
required at all for anything left in fedora? wouldnt dropping it solve the
problem then? Producer seems pretty much obsolete to me now.
Comment 7 Ralf Corsepius 2007-06-28 08:54:55 EDT
(In reply to comment #6)
> 1. dont see any cmake problems
I am seeing plenty. 

Using their build instructions, they don't build osgwrappers, don't build the
examples, don't build the docs, silently drop many optional packages and don't
even get CFLAGS right (which actually is a bug in Fedora cmake setup)

> and its better than the solution they had before.
True, OSG-1's setup hardly could be worse.
 
> (my personal opinion since i dont have anything against cmake compared to lets
> some selfhacked shellscript that builds things)
I do have a strong opinion against cmake: 

It's imake in new clothes, suffers from the same defects/flaws as imake and is
such kind of unflexible it is a sheer nightmare to maintainers/system
integrators. They don't consider new systems nor cross-compilation.
In short: Mal-designed junk.

> 2. cant you just build producer vs osg2?
This doesn't help much. It would equally break existing apps because they
already depend on OpenThreads-1 and Producer-1.

> tried it?
Nope.

> if it doesent work is it 
> required at all for anything left in fedora?
Nothing, I am aware about. But external stuff might depend on it ;)

> wouldnt dropping it solve the problem then?
IMO, this would be very (non-acceptably) harsh to users.

The real problem behind this is:
OSG-2 upgrades OpenThreads and OpenSceneGraph, but drops Producer _without
replacement_.

For yum to succeed, something would have to provide Producer, either via an
actual package (I.e. a new package would have to be introduced) or via
"obsoletes". The later would break existing apps.

> Producer seems pretty much obsolete to me now.
I am inclined to agree. May-be you are right and a brute-force 
Obsoletes: Producer < ...
is the way to go -- I am sure, users who have been investing man-years into work
against OSG-1 will send out a killer to me.

The less brutal way would be to introduce a new OSG-2 package.
It's devel packages would conflict with the current OSG-1 packages, but its
run-time packages could co-exist.

Comment 8 Ralf Corsepius 2007-11-28 23:35:23 EST
I've decided not to upgrade OSG on FC-7.

OSG-2.0.0 is part of FC-8. 

rawhide/FC-9 has been added OSG-2.2.0.


Note You need to log in before you can comment on or make changes to this bug.