Bug 244981 - don't start without LD_LIBRARY_PATH=/usr/lib with fglrx and Xgl
Summary: don't start without LD_LIBRARY_PATH=/usr/lib with fglrx and Xgl
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 12:01 UTC by Alphonse Van Assche
Modified: 2018-04-11 08:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:05:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alphonse Van Assche 2007-06-20 12:01:00 UTC
Description of problem:
Compiz don't start without LD_LIBRARY_PATH=/usr/lib with fglrx and Xgl.

Version-Release number of selected component (if applicable):
All versions.

How reproducible:
compiz --replace gconf 

Howto fix:
LD_LIBRARY_PATH=/usr/lib compiz --replace gconf 
  
Actual results:
compiz: GLX_SGIX_fbconfig is missing
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0

Expected results:
compiz simple work out of the box.

Additional info:
I have try LD_LIBRARY_PATH=/usr/lib compiz --replace gconf with the radeon
driver and AIGLX and all work like expect. desktop-effects fail with Xgl and
fglrx for the same reason.

Comment 1 Matěj Cepl 2007-10-29 15:05:31 UTC
Thanks for the report. We are sorry that we cannot help you with your problem, 
but we are not able to support binary-only drivers. If you would be able to 
reproduce this issue using only open source software, please, reopen this bug 
with the additional information, but in meantime I have no choice than to 
close this bug as CANTFIX (because we really cannot fix it).



Note You need to log in before you can comment on or make changes to this bug.