Bug 244987 - RHEL5.1 : iSCSI root install failure
Summary: RHEL5.1 : iSCSI root install failure
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Mike Christie
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 13:01 UTC by Mark McLoughlin
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 21:44:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McLoughlin 2007-06-20 13:01:05 UTC
With RHEL5-Server-20070620.nightly on x86_64, anaconda doesn't find my iSCSI target.

In anaconda.log I see:

  12:43:22 DEBUG   : iscsiadm -m discovery -t st -p 172.31.0.3:3260
  12:43:22 WARNING : didn't get what we expected from iscsiadm
  12:43:22 WARNING : unable to find portal information

If I try and run it myself, I get:

  # iscsiadm -m discovery -t st -p 172.31.0.3:3260
  iscsiadm: Could not make /var/lib/iscsi/ifaces. HW/OFFLOAD iscsi may not be
supported
  iscsiadm: Could not make /var/lib/iscsi/send_targets
  iscsiadm: can not update discovery record.
  iscsiadm: Could not make /var/lib/iscsi/nodes
  iscsiadm: Could not add record for iqn.1994-06.com.redhat.devel:markmc.test1
172.31.0.3,3260,1

If I manually create /var/lib/iscsi and login to the target all seems well.

Looks like iscsi-initiator-utils was re-based and the image build scripts needs
to include /var/lib/iscsi now.

Comment 1 Mike Christie 2007-06-20 16:58:03 UTC
We actually used /var/lib/iscsi before the update. The previous version would
create /var/lib/iscsi for other apps and installers that did not make it. I can
just add the code to the iscsi tools to do this again. I thought in some other
BZ someone said I should remove that code, but other distros will probably still
need it too.

Comment 2 Mark McLoughlin 2007-06-20 17:48:57 UTC
(In reply to comment #1)
> We actually used /var/lib/iscsi before the update. The previous version would
> create /var/lib/iscsi for other apps and installers that did not make it. I can
> just add the code to the iscsi tools to do this again. I thought in some other
> BZ someone said I should remove that code, but other distros will probably still
> need it too.

Yeah - that was me. I think my main point was that the RPM should install and
own the dir, not so much that the code should never create the dir.

I think it's valid for it to require that the dir pre-exists, but it's
unfortunate to make a change like that during RHEL5.

Comment 3 Mike Christie 2007-06-20 18:32:14 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > We actually used /var/lib/iscsi before the update. The previous version would
> > create /var/lib/iscsi for other apps and installers that did not make it. I can
> > just add the code to the iscsi tools to do this again. I thought in some other
> > BZ someone said I should remove that code, but other distros will probably still
> > need it too.
> 
> Yeah - that was me. I think my main point was that the RPM should install and
> own the dir, not so much that the code should never create the dir.
> 
> I think it's valid for it to require that the dir pre-exists, but it's
> unfortunate to make a change like that during RHEL5.

Yeah, understood. This is fixed in iscsi-initiator-utils-6.2.0.865-0.2.el5. It
was just built into brew.


Comment 4 RHEL Product and Program Management 2007-06-21 17:13:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Mark McLoughlin 2007-06-26 11:38:17 UTC
FWIW, it seems fine now with 6.2.0.865-0.4.el5

Comment 6 Mike Christie 2007-06-26 17:13:30 UTC
Thanks for testing.


Note You need to log in before you can comment on or make changes to this bug.