Bug 245017 - Revert broken in XEmacs (or file status?)
Revert broken in XEmacs (or file status?)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 11:40 EDT by Matt Fago
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 21.5.28-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 15:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XEmacs "send bug report" output (14.42 KB, text/plain)
2007-06-20 11:40 EDT, Matt Fago
no flags Details

  None (edit)
Description Matt Fago 2007-06-20 11:40:41 EDT
Description of problem:

XEmacs incorrectly thinks a file is modified even if it was just reverted.


Version-Release number of selected component (if applicable): 21.5.28-2

How reproducible: 100%

Steps to Reproduce:

1. Open a text file, e.g., test.txt that contains some content.
2. Modify the file but do not save
3. Revert the file
4. Notice that the file status at the bottom of the window still says
"modified" even though you just reverted the file. The contents of the
file _is_ reverted, XEmacs just doesn't "realize it."
5. Close the buffer: XEmacs asks if you want to save the file as "it
has been modified"
  
Actual results: XEmacs thinks the file is modified even after revert


Expected results: XEmacs does not think the file has been modified


Additional info:

Attached is the output from XEmacs "send bug report"
Comment 1 Matt Fago 2007-06-20 11:40:41 EDT
Created attachment 157476 [details]
XEmacs "send bug report" output
Comment 2 Ville Skyttä 2007-06-20 12:05:52 EDT
Reproduced.

I think this has been reported upstream recently, but I just posted about it
again to xemacs-beta because the only related thing I could find was
http://thread.gmane.org/gmane.emacs.xemacs.beta/25004/focus=25015 (which I
suppose is related).
Comment 3 Ville Skyttä 2007-06-24 06:02:20 EDT
Confirmed as an upstream bug and fixed there:
http://article.gmane.org/gmane.emacs.xemacs.patches/8296

The patch will be in xemacs >= 21.5.28-3 when released.
Comment 4 Fedora Update System 2007-07-02 12:06:39 EDT
xemacs-21.5.28-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-07-05 15:20:18 EDT
xemacs-21.5.28-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ville Skyttä 2007-07-05 15:25:05 EDT
The corresponding FE-6 update will be available shortly too, it's currently
being built.

Note You need to log in before you can comment on or make changes to this bug.