Bug 245128 - Evolution crash during boot in russian users
Evolution crash during boot in russian users
Status: CLOSED DUPLICATE of bug 242957
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.0
All Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 05:57 EDT by Mykola Ulianytskyi
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 00:28:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Ulianytskyi 2007-06-21 05:57:40 EDT
Description of problem:
Evolution crash during boot in russian users

Version-Release number of selected component (if applicable):
   evolution-2.8.0-33.0.1.el5
   evolution-data-server-1.8.0-15.0.3.el5

How reproducible:
   Always

Steps to Reproduce:
1. system-config-date
select
   Europe/Moscow

2. Create new user

3. Login by new user and run evolution
  
Memory status: size: 155791360 vsize: 0 resident: 155791360 share: 0 rss:
22855680 rss_rlim: 0
CPU usage: start_time: 1182419382 rtime: 0 utime: 73 stime: 0 cutime:68 cstime:
0 timeout: 5 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/evolution'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208669984 (LWP 4030)]
0x00a65402 in __kernel_vsyscall ()
#0  0x00a65402 in __kernel_vsyscall ()
#1  0x00cdfc33 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x009c1c26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  0x0805d9b9 in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#4  <signal handler called>
#5  0x00bd0daa in strcmp () from /lib/libc.so.6
#6  0x005f5949 in icaltimezone_get_builtin_timezone_from_offset () from
/usr/lib/libecal-1.2.so.7
#7  0x00cf34a5 in e_timezone_dialog_set_timezone () from
/usr/lib/evolution/2.8/libetimezonedialog.so.0
#8  0x00845006 in startup_wizard_timezone_page () from
/usr/lib/evolution/2.8/plugins/liborg-gnome-evolution-startup-wizard.so
#9  0x001364c6 in e_plugin_hook_register_type () from
/usr/lib/evolution/2.8/libeutil.so.0
#10 0x00135d31 in e_plugin_invoke () from /usr/lib/evolution/2.8/libeutil.so.0
#11 0x0012988b in e_config_page_check () from /usr/lib/evolution/2.8/libeutil.so.0
#12 0x0012a5d1 in e_config_target_changed () from
/usr/lib/evolution/2.8/libeutil.so.0
#13 0x0012b38c in e_config_create_widget () from
/usr/lib/evolution/2.8/libeutil.so.0
#14 0x0012b452 in e_config_create_window () from
/usr/lib/evolution/2.8/libeutil.so.0
#15 0x03442cf0 in em_account_editor_new () from
/usr/lib/evolution/2.8/components/libevolution-mail.so
#16 0x008450fe in startup_wizard () from
/usr/lib/evolution/2.8/plugins/liborg-gnome-evolution-startup-wizard.so
#17 0x001364c6 in e_plugin_hook_register_type () from
/usr/lib/evolution/2.8/libeutil.so.0
#18 0x00135d31 in e_plugin_invoke () from /usr/lib/evolution/2.8/libeutil.so.0
#19 0x00130b7a in e_event_get_type () from /usr/lib/evolution/2.8/libeutil.so.0
#20 0x00130ce9 in e_event_emit () from /usr/lib/evolution/2.8/libeutil.so.0
#21 0x08053454 in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#22 0x080538fe in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#23 0x08053a5d in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#24 0x0805dc37 in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#25 0x04159511 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
#26 0x0415b272 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x0415e24f in g_main_context_check () from /lib/libglib-2.0.so.0
#28 0x0415e5f9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#29 0x007a9943 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#30 0x0805d7ea in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#31 0x00b7adec in __libc_start_main () from /lib/libc.so.6
#32 0x0804f221 in ?? ()

Thread 1 (Thread -1208669984 (LWP 4030)):
#0  0x00a65402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00cdfc33 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x009c1c26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x0805d9b9 in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
No symbol table info available.
#4  <signal handler called>
No symbol table info available.
#5  0x00bd0daa in strcmp () from /lib/libc.so.6
No symbol table info available.
#6  0x005f5949 in icaltimezone_get_builtin_timezone_from_offset () from
/usr/lib/libecal-1.2.so.7
No symbol table info available.
#7  0x00cf34a5 in e_timezone_dialog_set_timezone () from
/usr/lib/evolution/2.8/libetimezonedialog.so.0
No symbol table info available.
#8  0x00845006 in startup_wizard_timezone_page () from
/usr/lib/evolution/2.8/plugins/liborg-gnome-evolution-startup-wizard.so
No symbol table info available.
#9  0x001364c6 in e_plugin_hook_register_type () from
/usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#10 0x00135d31 in e_plugin_invoke () from /usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#11 0x0012988b in e_config_page_check () from /usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#12 0x0012a5d1 in e_config_target_changed () from
/usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#13 0x0012b38c in e_config_create_widget () from
/usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#14 0x0012b452 in e_config_create_window () from
/usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#15 0x03442cf0 in em_account_editor_new () from
/usr/lib/evolution/2.8/components/libevolution-mail.so
No symbol table info available.
#16 0x008450fe in startup_wizard () from
/usr/lib/evolution/2.8/plugins/liborg-gnome-evolution-startup-wizard.so
No symbol table info available.
#17 0x001364c6 in e_plugin_hook_register_type () from
/usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#18 0x00135d31 in e_plugin_invoke () from /usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#19 0x00130b7a in e_event_get_type () from /usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#20 0x00130ce9 in e_event_emit () from /usr/lib/evolution/2.8/libeutil.so.0
No symbol table info available.
#21 0x08053454 in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
No symbol table info available.
#22 0x080538fe in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
No symbol table info available.
#23 0x08053a5d in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
No symbol table info available.
#24 0x0805dc37 in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
No symbol table info available.
#25 0x04159511 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
No symbol table info available.
#26 0x0415b272 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#27 0x0415e24f in g_main_context_check () from /lib/libglib-2.0.so.0
No symbol table info available.
#28 0x0415e5f9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#29 0x007a9943 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#30 0x0805d7ea in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
No symbol table info available.
#31 0x00b7adec in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#32 0x0804f221 in ?? ()
No symbol table info available.
#0  0x00a65402 in __kernel_vsyscall ()


Additional info:
   Evolution from FC6 has same bug.
   Evolution from FC7 works correctly.
Comment 1 Andy Shevchenko 2007-06-21 06:02:44 EDT
Reproduced on my FC6.
Comment 2 Matthew Barnes 2007-06-27 00:28:06 EDT
This will be fixed in RHEL 5.1.

*** This bug has been marked as a duplicate of 242957 ***

Note You need to log in before you can comment on or make changes to this bug.