Bug 245135 - Broadcom NetLink BCM5906M Fast Ethernet PCI Express does not work with RHEL5
Broadcom NetLink BCM5906M Fast Ethernet PCI Express does not work with RHEL5
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Andy Gospodarek
Martin Jenner
Depends On:
Blocks: 248654
  Show dependency treegraph
Reported: 2007-06-21 07:03 EDT by Lipika Pal
Modified: 2014-06-29 18:58 EDT (History)
9 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-07 14:53:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Sysreport (292.08 KB, application/x-bzip2)
2007-06-21 07:10 EDT, Lipika Pal
no flags Details
Kernel panic screen shot (505.02 KB, image/jpeg)
2007-08-01 01:51 EDT, Lipika Pal
no flags Details
5906.patch (712 bytes, patch)
2007-08-10 14:34 EDT, Andy Gospodarek
no flags Details | Diff

  None (edit)
Description Lipika Pal 2007-06-21 07:03:18 EDT
Description of problem:

Kernel version: 2.6.18-8.el

Steps to Reproduce:
1. With RHEL5 installed the Ethernet controller does not work; however the same
works with Fedora 7 and 'tg3' is the required module.

2. Following is the output for "lshal" mentioning the Ethernet details on Fedora 7:

  udi = '/org/freedesktop/Hal/devices/pci_14e4_1713'
  info.bus = 'pci'  (string)
  info.linux.driver = 'tg3'  (string)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_2843'  (string)
  info.product = 'NetLink BCM5906M Fast Ethernet PCI Express'  (string)
  info.subsystem = 'pci'  (string)
  info.udi = '/org/freedesktop/Hal/devices/pci_14e4_1713'  (string)
  info.vendor = 'Broadcom Corporation'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'pci'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1c.2/0000:18:00.0'  (string)
  pci.device_class = 2  (0x2)  (int)
  pci.device_protocol = 0  (0x0)  (int)
  pci.device_subclass = 0  (0x0)  (int)
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1c.2/0000:18:00.0' 
  pci.product = 'NetLink BCM5906M Fast Ethernet PCI Express'  (string)
  pci.product_id = 5907  (0x1713)  (int)
  pci.subsys_product_id = 12480  (0x30c0)  (int)
  pci.subsys_vendor = 'Hewlett-Packard Company'  (string)
  pci.subsys_vendor_id = 4156  (0x103c)  (int)
  pci.vendor = 'Broadcom Corporation'  (string)
  pci.vendor_id = 5348  (0x14e4)  (int)

Expected results: Kindly help to resolve the issue.
Comment 1 Lipika Pal 2007-06-21 07:10:51 EDT
Created attachment 157525 [details]
Comment 2 Ronald Pacheco 2007-07-17 18:51:40 EDT
This is on the HP nc6710s.

Adding HP to the bug so that they can assist.
Comment 3 Andy Gospodarek 2007-07-23 16:26:12 EDT
RHEL5.1 will contain the lastest tg3 driver upstream.  If it works on F7, there
is an excellent chance it will work on 5.1 as well.  Please test kernels here: 


and report back whether the networking is working or not.  Thanks!

Comment 4 RHEL Product and Program Management 2007-07-24 10:07:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 5 Ronald Pacheco 2007-07-26 14:31:44 EDT

Please have the driver in comment #3 tested and post the results in this BZ for
further action.
Comment 6 Maureen B. Smith Hoffert 2007-07-27 13:42:14 EDT
It is inappropriate for me to be assigned testing/validation since I have 
neither HW nor SW image. Please request this testing of the original submitter 
from RH India support team they have the HW and Customer image. Thanks, M
rajesh.dhingra@hp.com - tried to add to CC list, but was not accepted.
Comment 7 Andy Gospodarek 2007-07-27 15:11:17 EDT
If rajesh.dhingra@hp.com signs up for a bugzilla account they can be added to
the CC list.
Comment 8 Lipika Pal 2007-07-30 03:15:05 EDT
When tested with the new kernel downloaded from the Link mentioned above. 
The system gives Kernel Panic while booting up, just after starting udev.
Comment 9 Andy Gospodarek 2007-07-30 09:27:52 EDT
Can you copy the details of the panic here (like captured with a serial
console)?  Thanks!
Comment 10 Lawrence Lim 2007-07-31 01:44:39 EDT
smohan from Pune office mentioned that he has the hardware available to
facilitate the testing effort. Hence, if this bug gets included, we will help to
test this bug.
Comment 11 Lipika Pal 2007-08-01 01:51:36 EDT
Created attachment 160398 [details]
Kernel panic screen shot

As the serial console and the loop back cable is not available, the screen-shot
for the same has been attached.
Comment 12 Lipika Pal 2007-08-01 08:03:22 EDT
Network controller is still not working on RHEL5 Update1 beta. 

When tried with RHEL5 Update1 Beta, the installation went smooth in graphical
mode. But after installation, on rebooting the system, the kernel paniced. 

Thus, to check the network controller functionality, we tried installing the OS
using NFS method. 
On selecting NFS, OS was unable to load the appropriate Network driver. 
Then on selecting the Broadcom 'tg3' driver from the displayed list, the
following message was displayed:  "No device found" 
Comment 13 Ronald Pacheco 2007-08-05 09:10:41 EDT
Setting the exception flag for RHEL 5.1.

This feature, along with BZ 245143, alre required to support a 15K laptop
Comment 15 Andy Gospodarek 2007-08-07 08:55:03 EDT
Brian apparently has this laptop.  The panic in comment #11 seems to look like a
sound issue.  Are you working on that one, Brian?  Apparently the kernels in
comment #3 seem to cause this panic.
Comment 16 Brian Maly 2007-08-07 13:02:09 EDT
I did not see any panic on this system with any of the kernels I have tested,
but I will test the kernel in Comment #3 and report back my findings.

Comment 17 Ronald Pacheco 2007-08-08 11:24:50 EDT

Is the modem disabled on your laptop?  I'm wondering is the softmodem driver (a
binary blob) is causing the panic in comment #11, or another audio stream.
Comment 20 Andy Gospodarek 2007-08-10 14:34:16 EDT
Created attachment 161069 [details]

Brian has confirmed this patch will resolve the issue of the 5906M not working.
Comment 23 Don Zickus 2007-08-15 15:07:51 EDT
in 2.6.18-40.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 26 errata-xmlrpc 2007-11-07 14:53:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.