Bug 24519 - slocate cron job error
slocate cron job error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: slocate (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 25252 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-21 16:47 EST by Jeremy Katz
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-29 21:36:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-01-21 16:47:54 EST
/etc/cron.daily/slocate.cron:

fatal error: updatedb: create_db(): rename: No such file or directory


I think this may have begun happening only after updating to slocate-2.5-1,
but it seems I've got a couple messages about it sitting in the local
mailspool.
Comment 1 Helge Deller 2001-01-22 14:51:11 EST
I couldn't reproduce your problem here. After updating to slocate-2.5-1 no
errors occured, but when I removed /var/lib/slocate/slocate.db I got:
warning: updatedb: could not open database: /var/lib/slocate/slocate.db: No such
file or directory,
but afterwards it worked everytime without problems.

Please, check:
1. the existance of the /var/lib/slocate directory
2. remove all slocate.*-files there,
3. and try again by directly starting /etc/cron.daily/slocate.cron 
You should get one error, but after that it should work cleanly again.
Comment 2 Jeremy Katz 2001-01-22 15:06:42 EST
Even if only generated on the initial install on the slocate package, it still
shouldn't generate an error that gets mailed to root due to the confusion this
causes to users.  See bugs 13611 and 14222 for previous reports and resolutions
of this on older versions of slocate
Comment 3 Jeremy Katz 2001-01-29 21:36:07 EST
*** Bug 25252 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2001-01-31 13:21:16 EST
Fixed in 2.5-2; slocate-2.5-info patch was broken.

Note You need to log in before you can comment on or make changes to this bug.