Bug 245209 - pirut throws a tantrum unable to find repo
pirut throws a tantrum unable to find repo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 13:47 EDT by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 16:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from updater (1.73 KB, text/plain)
2007-06-21 13:47 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-06-21 13:47:53 EDT
Description of problem:

After "Software Updater" claimed that there were 3 updates
(actually it was seven packages which had updates) an attempt
to ask it to perform these endend up with a traceback and

RepoError: Cannot find a valid baseurl for repo: updates

A full traceback is attached.

The other possiblity was that a progress bar was filling up
an initial one fifth, or so, and after that everything was just
sitting there without any further progress.

An immediate follow up with 'yup update' completed the whole
update without any incidents.

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
don't know; I could not get very far with update although
the later, i.e. after an updates, listing and browsing through
packages in GUI did not show any anomalies.
Comment 1 Michal Jaegermann 2007-06-21 13:47:53 EDT
Created attachment 157559 [details]
backtrace from updater
Comment 2 Jeremy Katz 2007-06-21 14:15:54 EDT
Does this happen if you're not using the fastestmirror plugin?
Comment 3 Michal Jaegermann 2007-06-21 15:04:13 EDT
With the fastestmirror plugin turned off (I tried) it was just sitting
there doing stuck partway up a progress bar.  OTOH it was doing that
as well when 'fastestmirror' was turned on and only once came back
with a traceback so I really do not know.

This was yesterday when I was configuring some freshly installed
machine with F7.  Maybe some temporary inability to get to
mirrorlist?  Like I said - after that traceback I run right after
that 'yum update' from a command line and everything was fine; only
more updates was found than reported by pirut.
Comment 4 Jeremy Katz 2007-08-10 16:00:09 EDT
Okay, should at least be caught better in CVS now and give the user a reasonable
error message

Note You need to log in before you can comment on or make changes to this bug.