Bug 245232 - -24.el5 and later kernels cannot load nvidia driver
-24.el5 and later kernels cannot load nvidia driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Burke
Martin Jenner
:
Depends On:
Blocks: 429701 264821
  Show dependency treegraph
 
Reported: 2007-06-21 15:51 EDT by Jay Fenlason
Modified: 2014-08-31 19:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 11:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Fenlason 2007-06-21 15:51:30 EDT
Description of problem:
The nvidia module compiled against the RHEL-5 GA kernel will not load against 
kernel-2.6.18-24.el5 and higher.

Version-Release number of selected component (if applicable):
kernel-2.6.18-24.el5 and later

How reproducible:
always

Steps to Reproduce:
1.attempt to modprobe the nvidia.ko module
2.
3.
  
Actual results:
NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
NVRM: BAR0 is 0M @ 0x00000000 (PCI:0005:00.0)
NVRM: The system BIOS may have misconfigured your graphics card.
nvidia: probe of 0000:05:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!


Expected results:
nvidia module loads, X can use it

Additional info:
dzickus told me to create this bug.  The machine is 
fenlason-desk.boston.devel.redhat.com
Comment 1 Don Zickus 2007-06-22 10:53:21 EDT
Jeff, the reason I have you cc'd on here is because the problem started with the
-24.el5 kernel.  That kernel is the special jumbo-sata build.  I assume this
might have something to do with the sata prep patch.  

Also note this is an PCI-Express card, which is probably why no one else has
complianed and why I told Jay to file the bz regardless of people's opinion of
the driver in question.

Cheers,
Don
Comment 2 Larry Troan 2007-09-05 11:00:43 EDT
With RHEL5 GOLD, anaconda uses VESA and does graphical install. System comes up
in graphical mode using VESA.

With the above 5.1 beta, anaconda attempts to load the nv driver, crashes and
says it attempts to load VESA but never does and reverts to a text install. When
it performs first boot after the install, it comes up in text mode. Running
startx causes X to crash. The /etc/X11/xorg.conf file has the "nv" driver
specified. Editing the file and replacing the "nv" with "vesa" allows X to start.

This is a regression from RHEL5 caused by anaconda's attempt to use the nv
driver and then to unsuccessfully revert back to the vesa driver.  Since the
problem is that the nv driver has a bug that subseqently exposes this anaconda
bug, I an not setting the REGRESSION keyword for this bug and there is a manual
work-around.

Following files attached to Bug 264821.
- 5.1 sosreport with vesa driver manually specified in xorg.conf file
- rhel5.0-anaconda-logs.tar.gz
- rhel5.1-anaconda-logs.tar.gz


Note that the hardware I have must go back to Fujitsu this afternoon and I'm
unsure whether we have additional GeForce 8400M hardware elsewhere.
Comment 3 Jarod Wilson 2007-09-12 11:37:20 EDT
This looks like we've got two different problems thrown into the same bug now.
If I'm not mistaken, the original problem is that the binary nvidia driver from
nVidia, when built against GA, doesn't load on 5.1. The second problem is that
the nv driver doesn't properly support GF8000-series graphics cards.

Not sure what we can do about the former, seems nvidia is using an ABI we've not
whitelisted, so probably CLOSED->NOTABUG. The latter should probably be tracked
in a separate bug.
Comment 5 Don Zickus 2007-09-12 18:09:39 EDT
Note the kernel in question had a broken kabi at the time.  The kabi has been
fixed to match the one at GA time.  It would be interesting to try to see if the
latest RHEL-5.1 kernel (or snapshot for that matter, any one shall do) fixes the
issue.

Then again re-reading the issue again, I really doubt this is a kabi problem. 
However, we have had several patches in that area since then.  
Comment 6 Prarit Bhargava 2007-09-17 11:52:02 EDT
fenlason, could you retest based on comment #5?

P.
Comment 7 Jeff Burke 2007-09-25 13:46:53 EDT
I upgraded from RHEL5 GA to RHEL5.1 Snapshot#8 -48 kernel. The only way I could
get the nvidia driver loaded was to rebuild it against the -48 kernel. FYI I
used NVIDIA-Linux-x86-1.0-8762-pkg1.run from nvidia web site.

We may want to request a release note on this. Looks like it has been in
NeedInfo for Jay since 2007-09-17 11:52 EST
Comment 8 Linda Wang 2008-07-16 14:04:41 EDT
Jeff, Thank you for the info. Not to add more work to your plate, 
but you check it against RHEL5.2? 

If the problem described in Comment#4 goes away, then
we should just closed this issue.
Comment 14 Jeff Burke 2008-08-20 17:11:19 EDT
I the NVIDIA 173.14.12 driver with the 2.6.18-8.el5 kernel.
Reboot into 2.6.18-92.el5.
Then did A modprobe --set-version 2.6.18-8.el5 nvidia

nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:01:00.0 to 64
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.12  Thu Jul 17 18:10:24 PDT 2008

It loaded the module from this directory.
/lib/modules/2.6.18-8.el5/kernel/drivers/video

So it looks like it installs the driver from a previously built kernel.

Note: It installed with out issue. But when I tried to restart GDM the systems seemed to hang. But that is a completely different issue.
Comment 15 Jon Masters 2008-08-25 10:38:32 EDT
I hope we can establish contact with Nvidia folks again wrt. packaging up the driver using the official process - several other vendors recently came on board. Perhaps rdoty and I can ping them?
Comment 16 Jeff Burke 2008-08-25 11:07:31 EDT
Based on my testing. I believe this issue to be fixed. The original issue was "-24.el5 and later kernels cannot load nvidia driver". I tested successfully with the 2.6.18-92.el5 using a nvidia module built against the 2.6.18-8.el5 kernel.

Note You need to log in before you can comment on or make changes to this bug.