Bug 245245 - No good way to control word wrap
No good way to control word wrap
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 16:45 EDT by Robert Peterson
Modified: 2010-01-14 12:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-06 20:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 408707 None None None Never

  None (edit)
Description Robert Peterson 2007-06-21 16:45:26 EDT
Description of problem:
Evolution is really bad about word-wrapping and the ability to turn
it off.  Today I ditched Thunderbird and went to Evolution because
Thunderbird was taking liberties with my content, deleting spaces and
such.  I looked all over the Evolution preferences trying to find
settings relating to word wrap.  I found none.  IMHO, that's just bad.
So: under "Composer preferences" there should be a check box so I can
turn word wrap off.  In fact, I NEVER want word wrap because I always
do my own formatting, and often, I'm sending patches as inline text
that are destroyed by it. Email clients should NOT change my content.

Now I know there's a button that says "Preformat", but it's user-
unfriendly.  First of all, it's unclear what it means and that it has
anything to do with word wrap.  Second, there's a "Preformat"
in the body, and another "Preformat" under Format->Heading and it's
unclear which is which or what the difference is (if any).
Changing it after the fact doesn't seem to undo the damage, but I
didn't spend a lot of time playing with it either.

At the very least, you should be able to select a default text type
so you don't have to pull down "Preformat" for every email you
compose.  It needs to be a user preference.  Start it out as "Normal"
but let the user change it to default to Preformat.  I still think a 
simple check box for word wrap is more clear to ordinary users.

Version-Release number of selected component (if applicable):
evolution-2.8.3-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Compose an email
2. Select and paste in a bunch of source code from xemacs for example
3. Hit the send button
  
Actual results:
Your source code is destroyed by word-wrap.

Expected results:
Email should not take liberties with my content unless I allow it.

Additional info:
Sorry if I come off as sounding brash, but I shouldn't have to use mutt
to compose a simple email and have it arrive at the other end unscathed.
Programs like Thunderbird and Evolution can do better.
Comment 1 Matthew Barnes 2007-10-06 20:14:03 EDT
This sounds very much along the lines of Ben Kahn's blog post about useability
problems with Evolution's composer.

http://xkahn.zoned.net/blog/2007/02/18/fixing-the-evolution-composer/

He opened an upstream bug [1] to track the problem, and the upstream developers
(including myself) are laying the groundwork to start addressing these issues. 
Please feel free to add comments to the discussion upstream.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=408707
Comment 2 Sami Wagiaalla 2010-01-14 12:00:36 EST
I actually want Thunderbird to word wrap my message but leave patches alone.
I found this plug-in (https://addons.mozilla.org/en-US/thunderbird/addon/2351) which allows to user to easily toggle word wrap, but it is tedious to turn ww on and off.

Maybe the compose window should have a paste box which does not format content for pasting patches, code, etc. 

Or maybe just a seperator:

Message 

--Paste------------------------------

Patch

Note You need to log in before you can comment on or make changes to this bug.