Bug 245251 - FC7 doesn't load my external hard drives. Boots up with error.
FC7 doesn't load my external hard drives. Boots up with error.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jay Fenlason
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 17:26 EDT by amber
Modified: 2014-08-31 19:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6.22.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 14:14:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg in a text file (25.77 KB, text/plain)
2007-06-21 17:26 EDT, amber
no flags Details

  None (edit)
Description amber 2007-06-21 17:26:50 EDT
This is about my Western Digital external hard drives and Fedora Core 7's
firewire support.
Every time I reboot, when it comes back up and goes to load the external hard
drives, that are connected by firewire, I get this message while it's booting:
fw_sbp2: management write failed, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11

(there's more of the same message because I have 2 WD external HD's booting up)

When Fedora has fully booted, I don't have my firewire WD external hard drives
showing anywhere to use.

The last time I just tried "shutdown now" and it shutdown, then I turned off the
power to the external HD's and turned them back on. On the monitor screen, it
displayed this:
rfw_core:phy config: card 0, newroot=ffc2, gap_count=7
fw_sbp2: management write failed, rcode 0x11
fw_core: Unsolicited response (source ffc0, tlabel14)
fw_sbp2: orb reply times out, rcode 0x11
ebofw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: management write failed, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: failed to login to fw1.0
fw_sbp2: orb reply times out, rcode 0x11
fw_sbp2: failed to login to fw2.0

then just sat there with nothing to do...
I typed "reboot" then it rebooted and did it's normal routine I first mentioned
about, above.

I just want to be able to see my external HD's so I can use them, that's all. 

dmesg is attached if you would find it useful. For anything else you need, just ask.

Using:
Linux 2.6.21-1.3194.fc7
Comment 1 amber 2007-06-21 17:26:50 EDT
Created attachment 157574 [details]
dmesg in a text file
Comment 2 Stewart Adam 2007-06-21 19:09:21 EDT
I'm sorry but I can't help you much - fwfstab is only a GUI interface to the
fstab. This looks like a kernel problem, I'll reassign to the right person.
Comment 3 Henrik Johansson 2007-07-14 18:25:14 EDT
I have a similar problem on one of my FC7:s, I've upgraded this week.
The first computer I upgraded, has no problem to mount the Firewire-drive, 
the second doesn't mount it (I can't mount it manually).
It was no problem with the Firewire-drive in FC6. I can't remember the
kernel-versions in FC6, but I use to run the 'Software Updater' once a week.

Some data from the computer that can mount the drive:
[root@kank3 log]# uname -a
Linux kank3 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31 EDT 2007 i686 i686 i386
GNU/Linux

[root@kank3 log]# lspci -v -s 02:04.0
02:04.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller
(Link) (prog-if 10 [OHCI])
        Subsystem: Accton Technology Corporation Unknown device 1394
        Flags: bus master, medium devsel, latency 66, IRQ 19
        Memory at f8415000 (32-bit, non-prefetchable) [size=2K]
        Memory at f8410000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 1

[root@kank3 log]#
egrep from messages:
3319-Jul 14 21:06:40 kank3 kernel: scsi2 : SBP-2 IEEE-1394
3320-Jul 14 21:06:40 kank3 kernel: scsi 2:0:0:0: Direct-Access-RBC WDC WD40
0BB-00CAA0            PQ: 0 ANSI: 4
3321:Jul 14 21:06:41 kank3 kernel: SCSI device sdc: 78165360 512-byte hdwr
sectors (40021 MB)
3322:Jul 14 21:06:41 kank3 kernel: sdc: Write Protect is off
3323:Jul 14 21:06:41 kank3 kernel: SCSI device sdc: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
3324:Jul 14 21:06:41 kank3 kernel: SCSI device sdc: 78165360 512-byte hdwr
sectors (40021 MB)
3325:Jul 14 21:06:41 kank3 kernel: sdc: Write Protect is off
3326:Jul 14 21:06:41 kank3 kernel: SCSI device sdc: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
3327:Jul 14 21:06:41 kank3 kernel:  sdc: sdc1
3328:Jul 14 21:06:41 kank3 kernel: sd 2:0:0:0: Attached scsi disk sdc
3329-Jul 14 21:06:41 kank3 kernel: sd 2:0:0:0: Attached scsi generic sg4 type 14
3330-Jul 14 21:06:41 kank3 kernel: NET: Registered protocol family 10

Some data from the computer that can't mount the drive:
[root@ws004 log]# uname -a
Linux ws004 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31 EDT 2007 i686 i686 i386
GNU/Linux

[root@ws004 log]# lspci -v -s 02:0c.0
02:0c.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 [OrangeLink] Host
Controller (rev 03) (prog-if 10 [OHCI])
        Subsystem: Orange Micro Root hub
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at fafff000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [60] Power Management version 2

[root@ws004 log]#

egrep from messages:
276-Jul 14 21:57:04 ws004 kernel: scsi2 : SBP-2 IEEE-1394
277-Jul 14 21:57:04 ws004 kernel: scsi 2:0:0:0: Direct-Access-RBC WDC WD40
0BB-00CAA0            PQ: 0 ANSI: 4
278:Jul 14 21:57:04 ws004 kernel: SCSI device sdb: 78165360 512-byte hdwr
sectors (40021 MB)
279:Jul 14 21:57:04 ws004 kernel: sdb: Write Protect is off
280:Jul 14 21:57:04 ws004 kernel: SCSI device sdb: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
281:Jul 14 21:57:04 ws004 kernel: SCSI device sdb: 78165360 512-byte hdwr
sectors (40021 MB)
282:Jul 14 21:57:04 ws004 kernel: sdb: Write Protect is off
283:Jul 14 21:57:04 ws004 kernel: SCSI device sdb: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
284:Jul 14 21:57:04 ws004 kernel:  sdb:<6>sd 2:0:0:0: SCSI error: return code =
0x00020000
285:Jul 14 21:57:04 ws004 kernel: end_request: I/O error, dev sdb, sector 0
286:Jul 14 21:57:04 ws004 kernel: Buffer I/O error on device sdb, logical block 0
287-Jul 14 21:57:04 ws004 kernel: sd 2:0:0:0: SCSI error: return code = 0x00020000
288:Jul 14 21:57:04 ws004 kernel: end_request: I/O error, dev sdb, sector 0
289:Jul 14 21:57:04 ws004 kernel: Buffer I/O error on device sdb, logical block 0



Comment 4 Christopher Brown 2007-09-17 08:16:17 EDT
Hello folks,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? This might well be related
to use of the new firewire stack which Fedora 7 kernels utilise. I'm
re-assigning this to the firewire maintainer who may wish to review it further.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 5 Henrik Johansson 2007-09-17 12:56:32 EDT
My problem was solved between 2007-08-27 12:59 EST and 2007-08-29 13:17 EST, 
by software updates I assume. See more comments in Bug 250696. 

BR
Henrik
Comment 6 Christopher Brown 2007-09-17 14:14:25 EDT
Great news Henrik. Closing this bug then...

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.