Bug 245282 - It can't use a fixed VNC-Port when virt-manager creates VM
Summary: It can't use a fixed VNC-Port when virt-manager creates VM
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-22 05:06 UTC by Shigeki Sakamoto
Modified: 2008-03-17 14:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 14:36:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shigeki Sakamoto 2007-06-22 05:06:50 UTC
Description of problem:
It can use a fixed VNC-Port when virt-install creates VM.
But it can't use a fixed VNC-Port when virt-manager creates VM.

Version-Release number of selected component (if applicable):


How reproducible:
It is solved,
if the authentication function of Port is added to libvirt
and virt-manager sends a VNC-Port setting to virt-install.

Steps to Reproduce:
1.It add the authentication function of Port to libvirt.
2.It add a setting item of VNC-Port to wizard when virt-manager creates VM so 
that virt-manager can send a VNC-Port setting to virt-install.
  
Actual results:
It can't use a fixed VNC-Port when virt-manager creates VM now,
because there is not a setting item about VNC-Port.

Expected results:
It can use a fixed VNC-Port when virt-manager creates VM.

Additional info:

Comment 1 Cole Robinson 2008-03-17 14:36:09 UTC
Setting vnc settings during install time is something we have explicitly
avoided. Reason being that we consider this a niche case, and would rather most
users not incur the overhead of yet another install screen for settings most
won't change.

However, with current packages in f7 and f8, a display device can be added after
install to specify a static port, password, etc. This should be sufficient for
users who require a fixed port for the vnc display. Just go
vm->details->addhardware. 

Closing this as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.