Bug 245296 - Xvnc crashes upon exiting mythfrontend (mythtv)
Xvnc crashes upon exiting mythfrontend (mythtv)
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On: 243952
  Show dependency treegraph
Reported: 2007-06-22 04:26 EDT by Adam Tkac
Modified: 2013-04-30 19:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-20 08:02:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2007-06-22 04:26:34 EDT
+++ This bug was initially created as a clone of Bug #243952 +++

Description of problem:
Xvnc crashes upon exiting "mythfrontend" application (part of MythTV suite)

Version-Release number of selected component (if applicable):

How reproducible:
crashes every time

Steps to Reproduce:
1. start VNC server:
vncserver :2
2. bring up VNC viewer:
vncviewer :2
3. start mythfrontend in VNC session:
4. exit mythfrontend:
hit ESC, select "Yes"

Actual results:
Xvnc process dies

Expected results:
VNC process stays up

Additional info:
Here is a GDB stack trace made by attaching to Xvnc process:

Program received signal SIGSEGV, Segmentation fault.
0x08165aa2 in xmesa_check_and_update_buffer_size (xmctx=0x0, 
    drawBuffer=0xb77f2008) at xm_api.c:1887
1887       xmesa_get_window_size(xmctx->display, drawBuffer, &width, &height);
(gdb) bt
#0  0x08165aa2 in xmesa_check_and_update_buffer_size (xmctx=0x0, 
    drawBuffer=0xb77f2008) at xm_api.c:1887
#1  0x08168209 in XMesaResizeBuffers (b=0xb77f2008) at xm_api.c:2539
#2  0x080f8e10 in __glXMesaDrawableResize (base=0xa2723b0) at xf86glx.c:113
#3  0x080bfa1a in PositionWindow (pWin=0xa275e10, x=0, y=0) at glxscreens.c:230
#4  0x080942c9 in compPositionWindow (pWin=0xa275e10, x=0, y=0)
    at compwindow.c:202
#5  0x0808d6dc in ReparentWindow (pWin=0xa275e10, pParent=0x9a75248, 
    x=<value optimized out>, y=<value optimized out>, client=0x9ab9520)
    at window.c:2669
#6  0x0806ff35 in ProcReparentWindow (client=0x9ab9520) at dispatch.c:674
#7  0x080b97f1 in XaceCatchDispatchProc (client=0x9ab9520) at xace.c:281
#8  0x0807050a in Dispatch () at dispatch.c:457
#9  0x080815f5 in main (argc=19, argv=0xbfc07ab4, envp=Cannot access memory at
address 0x11
) at main.c:445
#10 0x00be0f70 in __libc_start_main () from /lib/libc.so.6
#11 0x0805f5d1 in _start ()

-- Additional comment from atkac@redhat.com on 2007-06-13 05:49 EST --
I'm unsure what "mythfrontend" is. Is it in Fedora package?  (yum says not for
me) If no, please point me on source tarball, I will create my own mythfrontend.

Regards, Adam

-- Additional comment from gtgj@pacbell.net on 2007-06-13 14:37 EST --
"mythfrontend" is part of the MythTV suite, which is primarily a PVR
application.  It is not distributed with Fedora.  The ATRpms repository has RPMs
for Fedora but I didn't try them.  A source tarball of version 0.20 can be
downloaded from:


Compilation requires a lot of packages.  Some of the possibly non-standard ones are:


There are detailed instructions for compiling and running on the web site, but
here is a quick and dirty way to reproduce the crash (which isn't normally how
you'd run this program):


tar xjf mythtv-0.20.tar.bz2
cd mythtv-0.20
./configure --disable-dts --disable-xrandr
qmake mythtv.pro
make install  # should install into /usr/local

Running (inside a VNC session):

export MYTHCONFDIR=$HOME/.mythtv-test
    # This directory will get created the first time

    # A bunch of error messages related to a non-existent MySQL database 
    # will scroll by.  You can ignore them for the purposes of
    # reproducing this crash.
    # After a couple of seconds, a full-screen dialog asking to select a
    # language will pop up.  Hit "Return".
    # Another dialog for database settings will show up.  Just hit
    # "Return" twice.
    # The VNC server will crash.

-- Additional comment from atkac@redhat.com on 2007-06-14 10:52 EST --
Hm. It looks like problem is in mythTV, not in Xvnc. When I tried run vnc like this

$Xvnc :1 -ac -rfbauth ~/.vnc/passwd

and in different terminal I run

$export DISPLAY=:1

Xvnc live but mythfrontend crash (after vncviewer join and hit enter). Also in
standard Xorg mythTV have problems.


-- Additional comment from gtgj@pacbell.net on 2007-06-15 03:36 EST --
Have you tried running with a window manager?  For some reason, Xvnc doesn't
seem to crash without one.  Also, it seems more likely to crash if vncviewer is
brought up earlier:

Xvnc :1 -ac -rfbauth ~/.vnc/passwd

In other shell:
vncviewer :1 &
DISPLAY=:1 fluxbox &
DISPLAY=:1 mythfrontend &

Hit "Return" three times in VNC session; Xvnc crashes.

Other than that, I don't know what else to tell you.  Does the backtrace I
reported earlier provide any useful information?

-- Additional comment from atkac@redhat.com on 2007-06-15 04:22 EST --
(In reply to comment #4)
> Other than that, I don't know what else to tell you.  Does the backtrace I
> reported earlier provide any useful information?
Of course. All backtraces provides useful debug info :) But it could be quite
hard find where problem exactly is. Let me check it. No additional info is needed


Xnest has same problems. Looks mythfrontend doing some nasty stuff. If you want
setup testcase (mythfrontend isn't part of Fedora) i will do it.
Comment 1 Adam Tkac 2007-09-20 08:02:40 EDT
Fixed now, looks that Mesa 7 has some update related to this

Note You need to log in before you can comment on or make changes to this bug.