Bug 245312 - iwl3945: signal strength drops to 0
iwl3945: signal strength drops to 0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 07:56 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 08:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-06-22 07:56:00 EDT
Description of problem:
I am not sure if it is network manager, or rather a kernel bug. If I associate
with the network using NM, signal strenght will occasionally drop to 0 and the
only way to resolve this problem is to rmmod/modprobe the module.
/var/log/messages says:
Jun 22 12:07:07 localhost NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0 
Jun 22 12:07:07 localhost NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0 
Jun 22 12:07:29 localhost kernel: iwl3945: ipw going down 
Jun 22 12:07:29 localhost kernel: iwl3945: Grabbing access while already held at
line 825

Version-Release number of selected component (if applicable):
NetworkManager-1:0.6.5-5.fc7
kernel-2.6.21-1.3228.fc7

How reproducible:
occasionally

Steps to Reproduce:
1. connect to wlan using NM
2. wait
  
Actual results:
signal strength drops to zero

Expected results:
connection is stable
Comment 1 Julian Sikorski 2007-08-06 08:09:14 EDT
Seems to be fixed now.

Note You need to log in before you can comment on or make changes to this bug.