Bug 245361 - Errors when trying to register with redhat network
Errors when trying to register with redhat network
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Jan Hutař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 13:19 EDT by Harison Phinizy
Modified: 2013-01-10 04:10 EST (History)
0 users

See Also:
Fixed In Version: 5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 10:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harison Phinizy 2007-06-22 13:19:40 EDT
New install of RH5, first time I endeavored in RH5 (used centos 5 with no 
issue). After the install I do the usual rhn_register and use my RedHat network 
credentials to utilize the available entitlements. I get the following error 
after I put in my user name and pass. Mind you, no X, all of this is done 
through the curses interface.

stdout:
An error has occurred:
up2date_client.rhnreg.InvalidDefaultError
See /var/log/up2date for more information

/var/log/up2date:

[Thu Jun 21 10:57:34 2007] rhn_register Traceback (most recent call last):
File "/usr/sbin/rhn_register", line 79, in ?
app.run()
File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
sys.exit(self.main() or 0)
File "/usr/sbin/rhn_register", line 64, in main
ui.main()
File "/usr/share/rhn/up2date_client/tui.py", line 1834, in main
tui.run()
File "/usr/share/rhn/up2date_client/tui.py", line 1745, in run
result = win.run()
File "/usr/share/rhn/up2date_client/tui.py", line 469, in run
self.passwordEntry.value())
File "/usr/share/rhn/up2date_client/tui.py", line 66, in tui_call_wrapper
results = func(*params)
File "/usr/share/rhn/up2date_client/rhnreg.py", line 807, in getPossibleOrgs
cachedOrgs.setDefaultOrg(orgsFromServer['default_org'])
File "/usr/share/rhn/up2date_client/rhnreg.py", line 764, in setDefaultOrg
raise InvalidDefaultError("Tried to set default org to %s. Valid "
up2date_client.rhnreg.InvalidDefaultError: Tried to set default org to 5446030. 
Valid values are []
Comment 1 James Bowes 2008-07-25 10:14:17 EDT
This bug has been resolved in the 5.2 release of Enterprise Linux

Note You need to log in before you can comment on or make changes to this bug.