Bug 245362 - Switch user will not work because .Xauthority file has moved
Summary: Switch user will not work because .Xauthority file has moved
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-22 17:26 UTC by Daniel Walsh
Modified: 2013-03-06 03:51 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-06-23 10:05:55 UTC


Attachments (Terms of Use)

Description Daniel Walsh 2007-06-22 17:26:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc8 Firefox/2.0.0.4

Description of problem:
Your user does not have permissions to create additional logins.  Check your ~/.Xauthority setup.

~/.Xauthority file badly configured or missing.
100 Not authenticated

.Xauthority no longer exists in Rawhide.   

> echo $XAUTHORITY 
/tmp/.gdmFJN9TT



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Try to switchuser
2.
3.

Actual Results:
Fails

Expected Results:
Succeeds

Additional info:

Comment 1 Daniel Walsh 2007-06-22 17:27:22 UTC
Also close button on error box does not close.  It does nothing,  Have to click
on  window close X

Comment 2 Matthias Clasen 2007-06-22 19:11:21 UTC
Dan, how are you trying to switch users, with the fast-user-switch applet ?
That works fine for me.

Comment 3 Daniel Walsh 2007-06-23 10:01:45 UTC
Yes with the applet.

Comment 4 Daniel Walsh 2007-06-23 10:05:55 UTC
Ok now it seems to be working.  I guess a yum update fixed it.


Note You need to log in before you can comment on or make changes to this bug.