Bug 245376 - Errors on shutdown with kerberos NFS filesystems mounted
Errors on shutdown with kerberos NFS filesystems mounted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 14:28 EDT by drew.middlesworth
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0651
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:15:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drew.middlesworth 2007-06-22 14:28:32 EDT
Description of problem:
rpcgssd init script shuts down rpc.gssd before autofs and netfs which causes
additional delays and unmount errors when using kerberos with NFS. I've fixed it
by changing the chkconfig shutdown number for rpcgssd from 69 to 79.


Version-Release number of selected component (if applicable):
nfs-utils-1.0.9-16.el5

How reproducible:
Always

Steps to Reproduce:
1. Enable rpcgssd through the normal means
2. Mount a kerberos NFS filesystem
3. Shutdown the machine.
  
Actual results:
Errors attempting to unmount kerberos NFS filesystems

Expected results:
Clean unmount of kerberos NFS filesystems

Additional info:
Comment 1 RHEL Product and Program Management 2007-06-25 08:04:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Steve Dickson 2007-06-26 23:43:37 EDT
Boy, I'm not seeing this at all... would it be possible
to log the errors your seeing and post them?

Also which kernel and nfs-utils version are you using?
Comment 4 drew.middlesworth 2007-06-29 17:38:04 EDT
The errors are in the form of:
Jun 29 14:20:22 kapow kernel: RPC: AUTH_GSS upcall timed out.
Jun 29 14:20:22 kapow kernel: Please check user daemon is running!

and creates about a 30 second delay on shutdown.

kernel-2.6.18-8.1.6.el5
nfs-utils-1.0.9-16.el5

It appears that the file systems don't like being unmounted during the autofs
and netfs shutdown when the rpc.gssd daemon is already turned off.
Comment 5 drew.middlesworth 2007-06-29 17:41:39 EDT
Just another quick note...

rpc.gssd has been enabled with a:
echo "SECURE_NFS=yes" >> /etc/sysconfig/nfs
Comment 6 Steve Dickson 2007-07-05 14:48:27 EDT
Fixed in nfs-utils-1.0.9-23.el5
Comment 9 Kostas Georgiou 2007-09-04 20:35:57 EDT
From a quick look it seems that for new installs this will work fine (not tested
yet though). 

Updates from 5.0 will still keep the old priority though until the admin does
something like: "chkconfig --del rpcidmapd; chkconfig --add rpcidmapd".
For example my F7 install which has the fix still had the old priority in the
init scripts (until a minute ago :) since I never noticed anything in the changelog.
Comment 20 Suzanne Yeghiayan 2007-09-17 15:33:24 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 25 errata-xmlrpc 2007-11-07 12:15:43 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0651.html

Note You need to log in before you can comment on or make changes to this bug.